]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
remove test.{manager,profile}
[empathy.git] / tests / Makefile.am
index 7f99eaf364c01e4411424df32a3fbfa6295f38b3..c49c2007fde9ad2119aa67e89462b5b712abbb3d 100644 (file)
@@ -1,73 +1,84 @@
-SUBDIRS = xml
+SUBDIRS = interactive xml certificates
 
 CLEANFILES=
 
-include $(top_srcdir)/rules/check.mak
-
-SUPPRESSIONS=valgrind.supp dlopen.supp
-
-EXTRA_DIST =           \
-       test.manager    \
-       test.profile
+SUPPRESSIONS=tp-glib.supp dlopen.supp
 
 AM_CPPFLAGS =                                          \
-       -I$(top_srcdir)                                 \
+       $(ERROR_CFLAGS)                                 \
+       -I$(top_srcdir)/libempathy                      \
+       -I$(top_srcdir)/libempathy-gtk                  \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
+       -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(TPAW_CFLAGS)                                  \
        $(WARN_CFLAGS)                                  \
-       $(DISABLE_DEPRECATED)
+       $(DISABLE_DEPRECATED)                           \
+       -DSRCDIR=\""$(abs_srcdir)"\"                    \
+       $(NULL)
 
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy/libempathy.la                \
-       $(EMPATHY_LIBS)
-
-noinst_PROGRAMS =                      \
-       contact-manager                 \
-       empetit                         \
-       test-empathy-presence-chooser   \
-       test-empathy-status-preset-dialog \
-       test-empathy-protocol-chooser
-
-contact_manager_SOURCES = contact-manager.c
-empetit_SOURCES = empetit.c
-test_empathy_presence_chooser_SOURCES = test-empathy-presence-chooser.c
-test_empathy_status_preset_dialog_SOURCES = test-empathy-status-preset-dialog.c
-test_empathy_protocol_chooser_SOURCES = test-empathy-protocol-chooser.c
-
-check_PROGRAMS = check-main
-TESTS = check-main
-check_main_SOURCES =                             \
-    check-main.c                                 \
-    check-helpers.c                              \
-    check-helpers.h                              \
-    check-libempathy.h                           \
-    check-empathy-utils.c                        \
-    check-empathy-helpers.h                      \
-    check-empathy-helpers.c                      \
-    check-irc-helper.h                           \
-    check-irc-helper.c                           \
-    check-empathy-irc-server.c                   \
-    check-empathy-irc-network.c                  \
-    check-empathy-irc-network-manager.c          \
-    check-empathy-chatroom.c                     \
-    check-empathy-chatroom-manager.c
-
-check_c_sources = \
-    $(check_main_SOURCES)
-include $(top_srcdir)/tools/check-coding-style.mk
-check-local: check-coding-style
-
-check_main_LDADD = \
-    @CHECK_LIBS@ \
-    $(top_builddir)/libempathy-gtk/libempathy-gtk.la   \
-    $(top_builddir)/libempathy/libempathy.la           \
-    $(AM_LDFLAGS)
-
-check_main_CFLAGS = \
-    @CHECK_CFLAGS@ \
-    $(AM_CFLAGS)
+       $(TPAW_LIBS)                                            \
+       $(EMPATHY_LIBS)                                         \
+       $(NULL)
+
+tests_list =  \
+     empathy-irc-server-test                     \
+     empathy-irc-network-test                    \
+     empathy-irc-network-manager-test            \
+     empathy-chatroom-test                       \
+     empathy-chatroom-manager-test               \
+     empathy-parser-test                         \
+     empathy-live-search-test                    \
+     empathy-tls-test
+
+noinst_PROGRAMS = $(tests_list)
+TESTS = $(tests_list)
+
+empathy_tls_test_SOURCES = empathy-tls-test.c \
+     test-helper.c test-helper.h \
+     mock-pkcs11.c mock-pkcs11.h
+
+empathy_irc_server_test_SOURCES = empathy-irc-server-test.c \
+     test-helper.c test-helper.h                       \
+     test-irc-helper.h test-irc-helper.c
+
+empathy_irc_network_test_SOURCES = empathy-irc-network-test.c \
+     test-helper.c test-helper.h                       \
+     test-irc-helper.h test-irc-helper.c
+
+empathy_irc_network_manager_test_SOURCES = empathy-irc-network-manager-test.c \
+     test-helper.c test-helper.h                       \
+     test-irc-helper.h test-irc-helper.c
+
+empathy_chatroom_test_SOURCES = empathy-chatroom-test.c \
+     test-helper.c test-helper.h
+
+empathy_chatroom_manager_test_SOURCES = empathy-chatroom-manager-test.c \
+     test-helper.c test-helper.h
+
+empathy_parser_test_SOURCES = empathy-parser-test.c \
+     test-helper.c test-helper.h
+
+empathy_live_search_test_SOURCES = empathy-live-search-test.c \
+     test-helper.c test-helper.h
 
 TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
                    MC_PROFILE_DIR=@abs_top_srcdir@/tests \
                    MC_MANAGER_DIR=@abs_top_srcdir@/tests
+
+test-report: test-report.xml
+       gtester-report $(top_builddir)/tests/$@.xml > \
+         $(top_builddir)/tests/$@.html
+
+test-report.xml: ${TESTS} test
+
+test: ${TESTS}
+       gtester -o test-report.xml -k --verbose ${TESTS}
+
+test-%: empathy-%-test
+       gtester -o $@-report.xml -k --verbose $<
+
+.PHONY: test test-report