]> git.0d.be Git - empathy.git/blobdiff - tools/Makefile.am
Add simple flymake support.
[empathy.git] / tools / Makefile.am
index bd1f4c00265566626d52d930e0350cfa06be440a..8662b44aee931f4372a840a4293cc20b749ed862 100644 (file)
@@ -1,3 +1,5 @@
+include $(top_srcdir)/tools/shave.mk
+
 abs_top_builddir = @abs_top_builddir@
 
 noinst_SCRIPTS = telepathy-glib-env
@@ -7,43 +9,53 @@ telepathy-glib-env: telepathy-glib-env.in Makefile
        chmod +x $@
 
 EXTRA_DIST = \
-    c-constants-generator.xsl \
+    c-constants-gen.py \
     check-coding-style.mk \
     check-c-style.sh \
     check-misc.sh \
     check-whitespace.sh \
-    c-interfaces-generator.xsl \
     doc-generator.xsl \
+    flymake.mk \
     glib-client-gen.py \
     glib-client-marshaller-gen.py \
-    glib-errors-enum-body.xsl \
-    glib-errors-enum-header.xsl \
-    glib-interfaces-generator.xsl \
-    glib-interfaces-body-generator.xsl \
+    glib-errors-enum-body-gen.py \
+    glib-errors-enum-header-gen.py \
     glib-ginterface-gen.py \
     glib-gtypes-generator.py \
+    glib-interfaces-gen.py \
     glib-signals-marshal-gen.py \
     gobject-foo.py \
     identity.xsl \
+    lcov.am \
+    libtpcodegen.py \
     libglibcodegen.py \
-    ls-interfaces.xsl \
-    make-all-async.xsl \
-    spec-to-introspect.xsl \
+    make-version-script.py \
+    telepathy.am \
     telepathy-glib-env.in \
     with-session-bus.sh
 
-CLEANFILES = libglibcodegen.pyc libglibcodegen.pyo $(noinst_SCRIPTS)
+CLEANFILES = libtpcodegen.pyc libtpcodegen.pyo libglibcodegen.pyc libglibcodegen.pyo $(noinst_SCRIPTS)
 
 all: $(EXTRA_DIST)
 
+libglibcodegen.py: libtpcodegen.py
+       $(QUIET_GEN)touch $@
+c-constants-gen.py: libglibcodegen.py
+       $(QUIET_GEN)touch $@
 glib-client-marshaller-gen.py: libglibcodegen.py
-       touch $@
+       $(QUIET_GEN)touch $@
+glib-errors-enum-body-gen.py: libglibcodegen.py
+       $(QUIET_GEN)touch $@
+glib-errors-enum-header-gen.py: libglibcodegen.py
+       $(QUIET_GEN)touch $@
 glib-ginterface-gen.py: libglibcodegen.py
-       touch $@
+       $(QUIET_GEN)touch $@
 glib-gtypes-generator.py: libglibcodegen.py
-       touch $@
+       $(QUIET_GEN)touch $@
+glib-interfaces-gen.py: libglibcodegen.py
+       $(QUIET_GEN)touch $@
 glib-signals-marshal-gen.py: libglibcodegen.py
-       touch $@
+       $(QUIET_GEN)touch $@
 
 TELEPATHY_SPEC_SRCDIR = $(top_srcdir)/../telepathy-spec
 maintainer-update-from-telepathy-spec: