]> git.0d.be Git - empathy.git/blobdiff - tools/Makefile.am
Add simple flymake support.
[empathy.git] / tools / Makefile.am
index 817100087e17b3cb160a1e2d9e3681d5aa9e5e0d..8662b44aee931f4372a840a4293cc20b749ed862 100644 (file)
@@ -1,3 +1,5 @@
+include $(top_srcdir)/tools/shave.mk
+
 abs_top_builddir = @abs_top_builddir@
 
 noinst_SCRIPTS = telepathy-glib-env
@@ -13,6 +15,7 @@ EXTRA_DIST = \
     check-misc.sh \
     check-whitespace.sh \
     doc-generator.xsl \
+    flymake.mk \
     glib-client-gen.py \
     glib-client-marshaller-gen.py \
     glib-errors-enum-body-gen.py \
@@ -36,23 +39,23 @@ CLEANFILES = libtpcodegen.pyc libtpcodegen.pyo libglibcodegen.pyc libglibcodegen
 all: $(EXTRA_DIST)
 
 libglibcodegen.py: libtpcodegen.py
-       touch $@
+       $(QUIET_GEN)touch $@
 c-constants-gen.py: libglibcodegen.py
-       touch $@
+       $(QUIET_GEN)touch $@
 glib-client-marshaller-gen.py: libglibcodegen.py
-       touch $@
+       $(QUIET_GEN)touch $@
 glib-errors-enum-body-gen.py: libglibcodegen.py
-       touch $@
+       $(QUIET_GEN)touch $@
 glib-errors-enum-header-gen.py: libglibcodegen.py
-       touch $@
+       $(QUIET_GEN)touch $@
 glib-ginterface-gen.py: libglibcodegen.py
-       touch $@
+       $(QUIET_GEN)touch $@
 glib-gtypes-generator.py: libglibcodegen.py
-       touch $@
+       $(QUIET_GEN)touch $@
 glib-interfaces-gen.py: libglibcodegen.py
-       touch $@
+       $(QUIET_GEN)touch $@
 glib-signals-marshal-gen.py: libglibcodegen.py
-       touch $@
+       $(QUIET_GEN)touch $@
 
 TELEPATHY_SPEC_SRCDIR = $(top_srcdir)/../telepathy-spec
 maintainer-update-from-telepathy-spec: