]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
Updated Galician translations for docs
[empathy.git] / tests / Makefile.am
index 8049dd56a17148a6569fe27c530ce84da322c84d..863282627e8a514ed761775291db9cf77521e6f4 100644 (file)
@@ -4,16 +4,14 @@ CLEANFILES=
 
 SUPPRESSIONS=tp-glib.supp dlopen.supp
 
-EXTRA_DIST =           \
-       test.manager    \
-       test.profile
-
 AM_CPPFLAGS =                                          \
        $(ERROR_CFLAGS)                                 \
-       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/libempathy                      \
+       -I$(top_srcdir)/libempathy-gtk                  \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(TPAW_CFLAGS)                                  \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)                           \
        -DSRCDIR=\""$(abs_srcdir)"\"                    \
@@ -22,6 +20,7 @@ AM_CPPFLAGS =                                         \
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy/libempathy.la                \
+       $(TPAW_LIBS)                                            \
        $(EMPATHY_LIBS)                                         \
        $(NULL)
 
@@ -32,8 +31,8 @@ tests_list =  \
      empathy-chatroom-test                       \
      empathy-chatroom-manager-test               \
      empathy-parser-test                         \
-     empathy-live-search-test
-     #empathy-tls-test
+     empathy-live-search-test                    \
+     empathy-tls-test
 
 noinst_PROGRAMS = $(tests_list)
 TESTS = $(tests_list)
@@ -66,6 +65,18 @@ empathy_parser_test_SOURCES = empathy-parser-test.c \
 empathy_live_search_test_SOURCES = empathy-live-search-test.c \
      test-helper.c test-helper.h
 
+check_c_sources = \
+    $(empathy_tls_test_SOURCES) \
+    $(empathy_irc_server_test_SOURCES) \
+    $(empathy_irc_network_test_SOURCES) \
+    $(empathy_irc_network_manager_test_SOURCES) \
+    $(empathy_chatroom_test_SOURCES) \
+    $(empathy_chatroom_manager_test_SOURCES) \
+    $(empathy_parser_test_SOURCES) \
+    $(empathy_live_search_test_SOURCES)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
 TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
                    MC_PROFILE_DIR=@abs_top_srcdir@/tests \
                    MC_MANAGER_DIR=@abs_top_srcdir@/tests