]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
account-settings: allow to change the service
[empathy.git] / tests / Makefile.am
index bc7407aacdbb290d588b8ee64b26a76adb7271d4..7bcfa5e49c4857a54c6134b5613912a7e84afd72 100644 (file)
@@ -2,9 +2,7 @@ SUBDIRS = interactive xml
 
 CLEANFILES=
 
-include $(top_srcdir)/rules/check.mak
-
-SUPPRESSIONS=valgrind.supp dlopen.supp
+SUPPRESSIONS=tp-glib.supp dlopen.supp
 
 EXTRA_DIST =           \
        test.manager    \
@@ -14,53 +12,56 @@ AM_CPPFLAGS =                                               \
        $(ERROR_CFLAGS)                                 \
        -I$(top_srcdir)                                 \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
+       -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)                                  \
-       $(DISABLE_DEPRECATED)
+       $(DISABLE_DEPRECATED)                           \
+       $(NULL)
 
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy/libempathy.la                \
-       $(EMPATHY_LIBS)
+       $(EMPATHY_LIBS)                                         \
+       $(NULL)
 
 TEST_PROGS =                                     \
-     empathy-utils-test
+     empathy-irc-server-test                     \
+     empathy-irc-network-test                    \
+     empathy-irc-network-manager-test            \
+     empathy-chatroom-test                       \
+     empathy-chatroom-manager-test               \
+     empathy-parser-test                         \
+     empathy-live-search-test                    \
+     empathy-tls-test
+
+empathy_tls_test_SOURCES = empathy-tls-test.c \
+     test-helper.c test-helper.h
+
+empathy_irc_server_test_SOURCES = empathy-irc-server-test.c \
+     test-helper.c test-helper.h                       \
+     test-irc-helper.h test-irc-helper.c
+
+empathy_irc_network_test_SOURCES = empathy-irc-network-test.c \
+     test-helper.c test-helper.h                       \
+     test-irc-helper.h test-irc-helper.c
+
+empathy_irc_network_manager_test_SOURCES = empathy-irc-network-manager-test.c \
+     test-helper.c test-helper.h                       \
+     test-irc-helper.h test-irc-helper.c
+
+empathy_chatroom_test_SOURCES = empathy-chatroom-test.c \
+     test-helper.c test-helper.h
+
+empathy_chatroom_manager_test_SOURCES = empathy-chatroom-manager-test.c \
+     test-helper.c test-helper.h
+
+empathy_parser_test_SOURCES = empathy-parser-test.c \
+     test-helper.c test-helper.h
 
-empathy_utils_test_SOURCES = empathy-utils-test.c \
+empathy_live_search_test_SOURCES = empathy-live-search-test.c \
      test-helper.c test-helper.h
 
-check_PROGRAMS = check-main $(TEST_PROGS)
-
-TESTS = check-main
-check_main_SOURCES =                             \
-    check-main.c                                 \
-    check-helpers.c                              \
-    check-helpers.h                              \
-    check-libempathy.h                           \
-    check-empathy-helpers.h                      \
-    check-empathy-helpers.c                      \
-    check-irc-helper.h                           \
-    check-irc-helper.c                           \
-    check-empathy-irc-server.c                   \
-    check-empathy-irc-network.c                  \
-    check-empathy-irc-network-manager.c          \
-    check-empathy-chatroom.c                     \
-    check-empathy-chatroom-manager.c
-
-check_c_sources = \
-    $(check_main_SOURCES)
-include $(top_srcdir)/tools/check-coding-style.mk
-check-local: test check-coding-style
-
-check_main_LDADD = \
-    @CHECK_LIBS@ \
-    $(top_builddir)/libempathy-gtk/libempathy-gtk.la   \
-    $(top_builddir)/libempathy/libempathy.la           \
-    $(AM_LDFLAGS)
-
-check_main_CFLAGS = \
-    @CHECK_CFLAGS@ \
-    $(AM_CFLAGS)
+check_PROGRAMS = $(TEST_PROGS)
 
 TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
                    MC_PROFILE_DIR=@abs_top_srcdir@/tests \