]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Updated Polish translation
[empathy.git] / src / Makefile.am
index 58bb6e3dc910414c89cd9888baa8ac08660e514a..a01b759a1948e233a4952a9a95146f81f9d1c750 100644 (file)
@@ -5,12 +5,15 @@ CPPFLAGS_COMMON =                                     \
        $(ERROR_CFLAGS)                                 \
        -I$(top_srcdir)                                 \
        -DG_LOG_DOMAIN=\"empathy\"                      \
+       -DBIN_DIR=\"$(bindir)\"                         \
        $(DISABLE_DEPRECATED)                           \
        $(WARN_CFLAGS)                                  \
        $(NULL)
 
+AM_LDFLAGS = -lm
 AM_CPPFLAGS =                                          \
        $(CPPFLAGS_COMMON)                              \
+       $(TPL_CFLAGS)                                   \
        $(LIBNOTIFY_CFLAGS)                             \
        $(LIBCHAMPLAIN_CFLAGS)                          \
        $(WEBKIT_CFLAGS)                                \
@@ -20,6 +23,7 @@ LDADD =                                                               \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy/libempathy.la                \
        $(top_builddir)/extensions/libemp-extensions.la         \
+       $(TPL_LIBS)                                             \
        $(LIBNOTIFY_LIBS)                                       \
        $(EMPATHY_LIBS)                                         \
        $(LIBCHAMPLAIN_LIBS)                                    \
@@ -77,6 +81,7 @@ endif
 bin_PROGRAMS =                 \
        empathy                 \
        empathy-accounts        \
+       empathy-debugger        \
        $(NULL)
 
 BUILT_SOURCES=
@@ -90,17 +95,22 @@ empathy_accounts_LDADD =                                            \
        libempathy-accounts-common.la                                   \
        $(NULL)
 
+empathy_debugger_SOURCES =                                             \
+       empathy-debug-window.c empathy-debug-window.h                   \
+       empathy-debugger.c                                              \
+       $(NULL)
+
 empathy_handwritten_source = \
        empathy-about-dialog.c empathy-about-dialog.h                   \
        empathy-call-window-fullscreen.c empathy-call-window-fullscreen.h \
        empathy-call-window.c empathy-call-window.h                     \
        empathy-chat-window.c empathy-chat-window.h                     \
        empathy-chatrooms-window.c empathy-chatrooms-window.h           \
-       empathy-debug-window.c empathy-debug-window.h                   \
        empathy-event-manager.c empathy-event-manager.h                 \
        empathy-ft-manager.c empathy-ft-manager.h                       \
        empathy-invite-participant-dialog.c empathy-invite-participant-dialog.h \
        empathy-main-window.c empathy-main-window.h                     \
+       empathy-migrate-butterfly-logs.c empathy-migrate-butterfly-logs.h \
        empathy-new-chatroom-dialog.c empathy-new-chatroom-dialog.h     \
        empathy-preferences.c empathy-preferences.h                     \
        empathy-sidebar.c empathy-sidebar.h                             \