]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Be more compatible with Facebook emoticon codes
[empathy.git] / src / Makefile.am
index db30af3f2cccf0b45e3bf11f5cc640ff923ae64f..8806ae45782e791f24fda07c79d4c3951039d781 100644 (file)
@@ -2,6 +2,7 @@ include $(top_srcdir)/tools/flymake.mk
 
 CPPFLAGS_COMMON =                                      \
        $(EMPATHY_CFLAGS)                               \
+       $(TPAW_CFLAGS)                                  \
        $(ERROR_CFLAGS)                                 \
        -I$(top_srcdir)/libempathy-gtk                  \
        -I$(top_srcdir)/libempathy                      \
@@ -27,6 +28,7 @@ LDADD =                                                               \
        $(top_builddir)/extensions/libemp-extensions.la         \
        $(GCR_LIBS)                                             \
        $(EMPATHY_LIBS)                                         \
+       $(TPAW_LIBS)                                            \
        $(LIBCHAMPLAIN_LIBS)                                    \
        $(UOA_LIBS)                                             \
        $(NULL)
@@ -84,6 +86,7 @@ empathy_auth_client_SOURCES =                                         \
        $(NULL)
 
 empathy_chat_SOURCES =                                         \
+       chat-manager-interface.c chat-manager-interface.h \
        empathy-about-dialog.c empathy-about-dialog.h                   \
        empathy-chat-manager.c empathy-chat-manager.h           \
        empathy-chat-window.c empathy-chat-window.h             \
@@ -152,6 +155,7 @@ empathy_handwritten_source = \
 
 empathy_SOURCES =                                                      \
        $(empathy_handwritten_source)                                   \
+       chat-manager-interface.c chat-manager-interface.h \
        $(NULL)
 
 empathy_LDADD =                                                                \
@@ -195,14 +199,25 @@ EXTRA_DIST =                      \
        $(autostart_DATA)       \
        $(ui_DATA)              \
        empathy-chat.js         \
-       empathy-chat.gresource.xml
+       empathy-chat.gresource.xml \
+       Chat_Manager.xml
 
 dist_man_MANS =                        \
        empathy.1 \
        empathy-accounts.1
 
+chat-manager-interface.c: chat-manager-interface.h
+chat-manager-interface.h: Makefile.am Chat_Manager.xml
+       gdbus-codegen \
+               --interface-prefix org.gnome.Empathy. \
+               --c-namespace EmpathyGen \
+               --generate-c-code chat-manager-interface \
+               Chat_Manager.xml
+
 BUILT_SOURCES = \
        $(nodist_empathy_chat_SOURCES) \
+       chat-manager-interface.c \
+       chat-manager-interface.h \
        $(NULL)
 
 CLEANFILES = $(BUILT_SOURCES)