]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Add shave support to build process.
[empathy.git] / libempathy / Makefile.am
index f35309942b9337a7dd74a8e8637869bd20d6d550..67966695ea91c56da87587882d25d7f18646a16c 100644 (file)
@@ -1,10 +1,14 @@
+include $(top_srcdir)/tools/shave.mk
+
 AM_CPPFLAGS =                                           \
        -I.                                             \
        -I$(top_srcdir)                                 \
        -I$(top_builddir)                               \
        -DDATADIR=\""$(datadir)"\"                      \
+       -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(LIBEMPATHY_CFLAGS)                            \
-       $(WARN_CFLAGS)
+       $(WARN_CFLAGS)                                  \
+       $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
        empathy-marshal.h                               \
@@ -16,33 +20,38 @@ BUILT_SOURCES =                                     \
 lib_LTLIBRARIES = libempathy.la
 
 libempathy_la_SOURCES =                                        \
-       empathy-avatar.c                                \
-       empathy-time.c                                  \
-       empathy-status-presets.c                        \
-       empathy-debug.c                                 \
-       empathy-utils.c                                 \
-       empathy-message.c                               \
-       empathy-chatroom-manager.c                      \
+       empathy-account-manager.c                       \
        empathy-chatroom.c                              \
+       empathy-chatroom-manager.c                      \
+       empathy-call-factory.c                          \
+       empathy-call-handler.c                          \
        empathy-contact.c                               \
        empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
        empathy-contact-manager.c                       \
-       empathy-contact-factory.c                       \
-       empathy-tp-contact-factory.c                    \
-       empathy-tp-group.c                              \
-       empathy-tp-contact-list.c                       \
-       empathy-tp-chat.c                               \
-       empathy-tp-roomlist.c                           \
-       empathy-tp-call.c                               \
+       empathy-contact-monitor.c                       \
+       empathy-debug.c                                 \
+       empathy-dispatcher.c                            \
+       empathy-dispatch-operation.c                    \
        empathy-idle.c                                  \
-       empathy-log-manager.c                           \
-       empathy-irc-network-manager.c                   \
        empathy-irc-network.c                           \
+       empathy-irc-network-manager.c                   \
        empathy-irc-server.c                            \
-       empathy-tubes.c                                 \
-       empathy-tube.c                                  \
-       empathy-tube-handler.c
+       empathy-log-manager.c                           \
+       empathy-log-store.c                             \
+       empathy-log-store-empathy.c                     \
+       empathy-message.c                               \
+       empathy-status-presets.c                        \
+       empathy-time.c                                  \
+       empathy-tp-call.c                               \
+       empathy-tp-chat.c                               \
+       empathy-tp-contact-factory.c                    \
+       empathy-tp-contact-list.c                       \
+       empathy-tp-file.c                               \
+       empathy-tp-roomlist.c                           \
+       empathy-tp-tube.c                               \
+       empathy-tube-handler.c                          \
+       empathy-utils.c
 
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
@@ -57,33 +66,39 @@ libempathy_la_LDFLAGS =             \
        -export-symbols-regex ^empathy_
 
 libempathy_headers =                           \
-       empathy-avatar.h                        \
-       empathy-time.h                          \
-       empathy-status-presets.h                \
-       empathy-debug.h                         \
-       empathy-utils.h                         \
-       empathy-message.h                       \
-       empathy-chatroom-manager.h              \
+       empathy-account-manager.h               \
        empathy-chatroom.h                      \
+       empathy-chatroom-manager.h              \
+       empathy-call-factory.h                  \
+       empathy-call-handler.h                  \
        empathy-contact.h                       \
        empathy-contact-groups.h                \
        empathy-contact-list.h                  \
        empathy-contact-manager.h               \
-       empathy-contact-factory.h               \
-       empathy-tp-contact-factory.h            \
-       empathy-tp-group.h                      \
-       empathy-tp-contact-list.h               \
-       empathy-tp-chat.h                       \
-       empathy-tp-roomlist.h                   \
-       empathy-tp-call.h                       \
+       empathy-contact-monitor.h               \
+       empathy-debug.h                         \
+       empathy-dispatcher.h                    \
+       empathy-dispatch-operation.h            \
        empathy-idle.h                          \
-       empathy-log-manager.h                   \
-       empathy-irc-network-manager.h           \
        empathy-irc-network.h                   \
+       empathy-irc-network-manager.h           \
        empathy-irc-server.h                    \
-       empathy-tubes.h                         \
-       empathy-tube.h                          \
-       empathy-tube-handler.h
+       empathy-log-manager.h                   \
+       empathy-log-store.h                     \
+       empathy-log-store-empathy.h             \
+       empathy-message.h                       \
+       empathy-status-presets.h                \
+       empathy-time.h                          \
+       empathy-tp-call.h                       \
+       empathy-tp-chat.h                       \
+       empathy-tp-contact-factory.h            \
+       empathy-tp-contact-list.h               \
+       empathy-tp-file.h                       \
+       empathy-tp-roomlist.h                   \
+       empathy-tp-tube.h                       \
+       empathy-tube-handler.h                  \
+       empathy-types.h                         \
+       empathy-utils.h
 
 libempathy_includedir = $(includedir)/libempathy/
 libempathy_include_HEADERS =                   \
@@ -91,7 +106,7 @@ libempathy_include_HEADERS =                 \
        empathy-enum-types.h
 
 empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
-       ( cd $(srcdir) && \
+       $(QUIET_GEN)( cd $(srcdir) && \
        sed -n -e 's/.*empathy_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
        $(libempathy_la_SOURCES) ) \
        | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
@@ -102,16 +117,16 @@ empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
        fi
 
 %-marshal.h: %-marshal.list Makefile
-       $(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+       $(QUIET_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
 
 %-marshal.c: %-marshal.list Makefile
-       echo "#include \"empathy-marshal.h\"" > $@ && \
+       $(QUIET_GEN)echo "#include \"empathy-marshal.h\"" > $@ && \
        $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
 
 empathy-enum-types.h: stamp-empathy-enum-types.h
-       @true
+       $(QUIET_GEN)true
 stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
-       (cd $(srcdir) \
+       $(QUIET_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#ifndef __LIBEMPATHY_ENUM_TYPES_H__\n" \
                        --fhead "#define __LIBEMPATHY_ENUM_TYPES_H__ 1\n\n" \
@@ -128,7 +143,7 @@ stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
        && echo timestamp > $(@F)
 
 empathy-enum-types.c: $(libempathy_headers) Makefile
-       (cd $(srcdir) \
+       $(QUIET_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#include <config.h>\n" \
                        --fhead "#include <glib-object.h>\n" \