]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Add shave support to build process.
[empathy.git] / libempathy / Makefile.am
index c24a16f211d88188e51d2d9f124eefbc34854ddf..67966695ea91c56da87587882d25d7f18646a16c 100644 (file)
+include $(top_srcdir)/tools/shave.mk
+
 AM_CPPFLAGS =                                           \
        -I.                                             \
        -I$(top_srcdir)                                 \
+       -I$(top_builddir)                               \
        -DDATADIR=\""$(datadir)"\"                      \
+       -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(LIBEMPATHY_CFLAGS)                            \
-       $(WARN_CFLAGS)
+       $(WARN_CFLAGS)                                  \
+       $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
        empathy-marshal.h                               \
        empathy-marshal.c                               \
+       empathy-marshal.list                            \
        empathy-enum-types.h                            \
-       empathy-enum-types.c                            \
-       empathy-filter-glue.h                           \
-       empathy-chandler-glue.h
+       empathy-enum-types.c
 
 lib_LTLIBRARIES = libempathy.la
 
 libempathy_la_SOURCES =                                        \
-       empathy-conf.c                                  \
-       empathy-avatar.c                                \
-       empathy-time.c                                  \
-       empathy-presence.c                              \
-       empathy-debug.c                                 \
-       empathy-utils.c                                 \
-       empathy-message.c                               \
-       empathy-chatroom-manager.c                      \
+       empathy-account-manager.c                       \
        empathy-chatroom.c                              \
+       empathy-chatroom-manager.c                      \
+       empathy-call-factory.c                          \
+       empathy-call-handler.c                          \
        empathy-contact.c                               \
+       empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
        empathy-contact-manager.c                       \
-       empathy-contact-factory.c                       \
-       empathy-tp-group.c                              \
-       empathy-tp-contact-list.c                       \
+       empathy-contact-monitor.c                       \
+       empathy-debug.c                                 \
+       empathy-dispatcher.c                            \
+       empathy-dispatch-operation.c                    \
+       empathy-idle.c                                  \
+       empathy-irc-network.c                           \
+       empathy-irc-network-manager.c                   \
+       empathy-irc-server.c                            \
+       empathy-log-manager.c                           \
+       empathy-log-store.c                             \
+       empathy-log-store-empathy.c                     \
+       empathy-message.c                               \
+       empathy-status-presets.c                        \
+       empathy-time.c                                  \
+       empathy-tp-call.c                               \
        empathy-tp-chat.c                               \
-       empathy-tp-chatroom.c                           \
+       empathy-tp-contact-factory.c                    \
+       empathy-tp-contact-list.c                       \
+       empathy-tp-file.c                               \
        empathy-tp-roomlist.c                           \
-       empathy-chandler.c                              \
-       empathy-filter.c                                \
-       empathy-idle.c                                  \
-       empathy-log-manager.c
+       empathy-tp-tube.c                               \
+       empathy-tube-handler.c                          \
+       empathy-utils.c
 
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_la_LIBADD =         \
+       $(top_builddir)/extensions/libemp-extensions.la \
        $(LIBEMPATHY_LIBS)
 
 libempathy_la_LDFLAGS =                \
-       -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE}
+       -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE} \
+       -export-symbols-regex ^empathy_
 
 libempathy_headers =                           \
-       empathy-conf.h                          \
-       empathy-avatar.h                        \
-       empathy-time.h                          \
-       empathy-presence.h                      \
-       empathy-debug.h                         \
-       empathy-utils.h                         \
-       empathy-message.h                       \
-       empathy-chatroom-manager.h              \
+       empathy-account-manager.h               \
        empathy-chatroom.h                      \
+       empathy-chatroom-manager.h              \
+       empathy-call-factory.h                  \
+       empathy-call-handler.h                  \
        empathy-contact.h                       \
+       empathy-contact-groups.h                \
        empathy-contact-list.h                  \
        empathy-contact-manager.h               \
-       empathy-contact-factory.h               \
-       empathy-tp-group.h                      \
-       empathy-tp-contact-list.h               \
+       empathy-contact-monitor.h               \
+       empathy-debug.h                         \
+       empathy-dispatcher.h                    \
+       empathy-dispatch-operation.h            \
+       empathy-idle.h                          \
+       empathy-irc-network.h                   \
+       empathy-irc-network-manager.h           \
+       empathy-irc-server.h                    \
+       empathy-log-manager.h                   \
+       empathy-log-store.h                     \
+       empathy-log-store-empathy.h             \
+       empathy-message.h                       \
+       empathy-status-presets.h                \
+       empathy-time.h                          \
+       empathy-tp-call.h                       \
        empathy-tp-chat.h                       \
-       empathy-tp-chatroom.h                   \
+       empathy-tp-contact-factory.h            \
+       empathy-tp-contact-list.h               \
+       empathy-tp-file.h                       \
        empathy-tp-roomlist.h                   \
-       empathy-chandler.h                      \
-       empathy-filter.h                        \
-       empathy-idle.h                          \
-       empathy-log-manager.h
+       empathy-tp-tube.h                       \
+       empathy-tube-handler.h                  \
+       empathy-types.h                         \
+       empathy-utils.h
 
 libempathy_includedir = $(includedir)/libempathy/
 libempathy_include_HEADERS =                   \
        $(libempathy_headers)                   \
        empathy-enum-types.h
 
-%-marshal.h: %-marshal.list Makefile.am
-       $(GLIB_GENMARSHAL) --header --prefix=$(subst -,_,$*)_marshal $< > $*-marshal.h
-
-%-marshal.c: %-marshal.list Makefile.am
-       echo "#include \"empathy-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=$(subst -,_,$*)_marshal $< >> $*-marshal.c
+empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
+       $(QUIET_GEN)( cd $(srcdir) && \
+       sed -n -e 's/.*empathy_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
+       $(libempathy_la_SOURCES) ) \
+       | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
+       if cmp -s $@.tmp $@; then \
+               rm $@.tmp; \
+       else \
+               mv $@.tmp $@; \
+       fi
 
-%-marshal-main.c: %-marshal.c %-marshal.h
+%-marshal.h: %-marshal.list Makefile
+       $(QUIET_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
 
-empathy-chandler-glue.h: empathy-chandler.xml
-       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_chandler --mode=glib-server --output=$@ $<
-empathy-filter-glue.h: empathy-filter.xml
-       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-server --output=$@ $<
+%-marshal.c: %-marshal.list Makefile
+       $(QUIET_GEN)echo "#include \"empathy-marshal.h\"" > $@ && \
+       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
 
 empathy-enum-types.h: stamp-empathy-enum-types.h
-       @true
-stamp-empathy-enum-types.h: Makefile $(libempathy_headers)
-       (cd $(srcdir) \
+       $(QUIET_GEN)true
+stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
+       $(QUIET_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#ifndef __LIBEMPATHY_ENUM_TYPES_H__\n" \
                        --fhead "#define __LIBEMPATHY_ENUM_TYPES_H__ 1\n\n" \
@@ -111,8 +142,8 @@ stamp-empathy-enum-types.h: Makefile $(libempathy_headers)
        && rm -f xgen-gth \
        && echo timestamp > $(@F)
 
-empathy-enum-types.c: Makefile $(libempathy_headers)
-       (cd $(srcdir) \
+empathy-enum-types.c: $(libempathy_headers) Makefile
+       $(QUIET_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#include <config.h>\n" \
                        --fhead "#include <glib-object.h>\n" \
@@ -132,21 +163,27 @@ empathy-enum-types.c: Makefile $(libempathy_headers)
 
 dtddir = $(datadir)/empathy
 dtd_DATA =                                     \
-       empathy-chatroom-manager.dtd
+       empathy-status-presets.dtd              \
+       empathy-contact-groups.dtd              \
+       empathy-chatroom-manager.dtd            \
+       empathy-irc-networks.dtd
 
 stylesheetdir = $(datadir)/empathy
 stylesheet_DATA =              \
        empathy-log-manager.xsl
 
+ircnetworksdir = $(datadir)/empathy
+ircnetworks_DATA =             \
+       irc-networks.xml
+
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = libempathy.pc
 
 EXTRA_DIST =                   \
        empathy-marshal.list    \
-       empathy-chandler.xml    \
-       empathy-filter.xml      \
        $(stylesheet_DATA)      \
-       $(dtd_DATA)
+       $(dtd_DATA)             \
+       $(ircnetworks_DATA)
 
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \