]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
build: use an autoconf macro to get to -lm
[empathy.git] / libempathy / Makefile.am
index cfea24c0e6c8c501fca3afd1f51f5d3742c6397d..3cd971a5d2b7e0ca0488e6163f2e91acba033465 100644 (file)
@@ -10,9 +10,12 @@ AM_CPPFLAGS =                                           \
        -DG_LOG_DOMAIN=\"empathy\"                      \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(YELL_CFLAGS)                                  \
        $(GEOCLUE_CFLAGS)                               \
+       $(GEOCODE_CFLAGS)                               \
        $(NETWORK_MANAGER_CFLAGS)                       \
        $(CONNMAN_CFLAGS)                               \
+       $(UDEV_CFLAGS)                                  \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -26,11 +29,13 @@ BUILT_SOURCES =                                     \
 noinst_LTLIBRARIES = libempathy.la
 
 libempathy_headers =                           \
+       action-chain-internal.h                 \
        empathy-account-settings.h              \
        empathy-auth-factory.h                  \
-       empathy-channel-factory.h \
+       empathy-camera-monitor.h                \
        empathy-chatroom-manager.h              \
        empathy-chatroom.h                      \
+       empathy-client-factory.h \
        empathy-connection-managers.h           \
        empathy-connectivity.h                  \
        empathy-contact-groups.h                \
@@ -65,13 +70,15 @@ libempathy_headers =                                \
        empathy-types.h                         \
        empathy-utils.h
 
-libempathy_la_SOURCES =                                        \
+libempathy_handwritten_source =                                \
        $(libempathy_headers)                           \
+       action-chain.c                                  \
        empathy-account-settings.c                      \
        empathy-auth-factory.c                          \
-       empathy-channel-factory.c \
+       empathy-camera-monitor.c                        \
        empathy-chatroom-manager.c                      \
        empathy-chatroom.c                              \
+       empathy-client-factory.c \
        empathy-connection-managers.c                   \
        empathy-connectivity.c                          \
        empathy-contact-groups.c                        \
@@ -103,21 +110,28 @@ libempathy_la_SOURCES =                                   \
        empathy-tp-streamed-media.c                     \
        empathy-utils.c
 
+libempathy_la_SOURCES = \
+       $(libempathy_handwritten_source) \
+       cheese-camera-device-monitor.c cheese-camera-device-monitor.h
+
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_la_LIBADD =         \
        $(top_builddir)/extensions/libemp-extensions.la \
+       $(top_builddir)/telepathy-yell/telepathy-yell/libtelepathy-yell.la \
        $(GCR_LIBS) \
        $(EMPATHY_LIBS) \
        $(GEOCLUE_LIBS) \
+       $(GEOCODE_LIBS) \
        $(NETWORK_MANAGER_LIBS) \
-       $(CONNMAN_LIBS)
+       $(CONNMAN_LIBS) \
+       $(UDEV_LIBS) \
+       $(LIBM)
 
 check_c_sources = \
-    $(libempathy_la_SOURCES) \
-    $(libempathy_headers)
+    $(libempathy_handwritten_source)
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
@@ -132,12 +146,12 @@ empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
                mv $@.tmp $@; \
        fi
 
-%-marshal.h: %-marshal.list Makefile
-       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+empathy-marshal.h: empathy-marshal.list Makefile
+       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_empathy_marshal $< > empathy-marshal.h
 
-%-marshal.c: %-marshal.list Makefile
+empathy-marshal.c: empathy-marshal.list Makefile
        $(AM_V_GEN)echo "#include \"empathy-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
+       $(GLIB_GENMARSHAL) --body --prefix=_empathy_marshal $< >> empathy-marshal.c
 
 empathy-enum-types.h: stamp-empathy-enum-types.h
        $(AM_V_GEN)true