]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
build: use an autoconf macro to get to -lm
[empathy.git] / libempathy / Makefile.am
index 5122e073d6d67d5cec0ac59b18a8b1d7d6085fc7..3cd971a5d2b7e0ca0488e6163f2e91acba033465 100644 (file)
@@ -8,10 +8,14 @@ AM_CPPFLAGS =                                           \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
        -DG_LOG_DOMAIN=\"empathy\"                      \
+       -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(YELL_CFLAGS)                                  \
        $(GEOCLUE_CFLAGS)                               \
+       $(GEOCODE_CFLAGS)                               \
        $(NETWORK_MANAGER_CFLAGS)                       \
        $(CONNMAN_CFLAGS)                               \
+       $(UDEV_CFLAGS)                                  \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -25,12 +29,13 @@ BUILT_SOURCES =                                     \
 noinst_LTLIBRARIES = libempathy.la
 
 libempathy_headers =                           \
+       action-chain-internal.h                 \
        empathy-account-settings.h              \
        empathy-auth-factory.h                  \
-       empathy-call-factory.h                  \
-       empathy-call-handler.h                  \
+       empathy-camera-monitor.h                \
        empathy-chatroom-manager.h              \
        empathy-chatroom.h                      \
+       empathy-client-factory.h \
        empathy-connection-managers.h           \
        empathy-connectivity.h                  \
        empathy-contact-groups.h                \
@@ -38,40 +43,42 @@ libempathy_headers =                                \
        empathy-contact-manager.h               \
        empathy-contact.h                       \
        empathy-debug.h                         \
-       empathy-dispatcher.h                    \
        empathy-ft-factory.h                    \
        empathy-ft-handler.h                    \
        empathy-gsettings.h                     \
-       empathy-idle.h                          \
+       empathy-presence-manager.h                              \
        empathy-individual-manager.h            \
        empathy-irc-network-manager.h           \
        empathy-irc-network.h                   \
        empathy-irc-server.h                    \
+       empathy-keyring.h                       \
        empathy-location.h                      \
        empathy-message.h                       \
+       empathy-request-util.h                  \
        empathy-server-sasl-handler.h           \
        empathy-server-tls-handler.h            \
        empathy-status-presets.h                \
        empathy-time.h                          \
        empathy-tls-certificate.h               \
        empathy-tls-verifier.h                  \
-       empathy-tp-call.h                       \
        empathy-tp-chat.h                       \
        empathy-tp-contact-factory.h            \
        empathy-tp-contact-list.h               \
        empathy-tp-file.h                       \
        empathy-tp-roomlist.h                   \
+       empathy-tp-streamed-media.h             \
        empathy-types.h                         \
        empathy-utils.h
 
-libempathy_la_SOURCES =                                        \
+libempathy_handwritten_source =                                \
        $(libempathy_headers)                           \
+       action-chain.c                                  \
        empathy-account-settings.c                      \
        empathy-auth-factory.c                          \
-       empathy-call-factory.c                          \
-       empathy-call-handler.c                          \
+       empathy-camera-monitor.c                        \
        empathy-chatroom-manager.c                      \
        empathy-chatroom.c                              \
+       empathy-client-factory.c \
        empathy-connection-managers.c                   \
        empathy-connectivity.c                          \
        empathy-contact-groups.c                        \
@@ -79,43 +86,52 @@ libempathy_la_SOURCES =                                     \
        empathy-contact-manager.c                       \
        empathy-contact.c                               \
        empathy-debug.c                                 \
-       empathy-dispatcher.c                            \
        empathy-ft-factory.c                            \
        empathy-ft-handler.c                            \
-       empathy-idle.c                                  \
+       empathy-presence-manager.c                                      \
        empathy-individual-manager.c                    \
        empathy-irc-network-manager.c                   \
        empathy-irc-network.c                           \
        empathy-irc-server.c                            \
+       empathy-keyring.c                               \
        empathy-message.c                               \
+       empathy-request-util.c                          \
        empathy-server-sasl-handler.c                   \
        empathy-server-tls-handler.c                    \
        empathy-status-presets.c                        \
        empathy-time.c                                  \
        empathy-tls-certificate.c                       \
        empathy-tls-verifier.c                          \
-       empathy-tp-call.c                               \
        empathy-tp-chat.c                               \
        empathy-tp-contact-factory.c                    \
        empathy-tp-contact-list.c                       \
        empathy-tp-file.c                               \
        empathy-tp-roomlist.c                           \
+       empathy-tp-streamed-media.c                     \
        empathy-utils.c
 
+libempathy_la_SOURCES = \
+       $(libempathy_handwritten_source) \
+       cheese-camera-device-monitor.c cheese-camera-device-monitor.h
+
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_la_LIBADD =         \
        $(top_builddir)/extensions/libemp-extensions.la \
+       $(top_builddir)/telepathy-yell/telepathy-yell/libtelepathy-yell.la \
+       $(GCR_LIBS) \
        $(EMPATHY_LIBS) \
        $(GEOCLUE_LIBS) \
+       $(GEOCODE_LIBS) \
        $(NETWORK_MANAGER_LIBS) \
-       $(CONNMAN_LIBS)
+       $(CONNMAN_LIBS) \
+       $(UDEV_LIBS) \
+       $(LIBM)
 
 check_c_sources = \
-    $(libempathy_la_SOURCES) \
-    $(libempathy_headers)
+    $(libempathy_handwritten_source)
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
@@ -130,12 +146,12 @@ empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
                mv $@.tmp $@; \
        fi
 
-%-marshal.h: %-marshal.list Makefile
-       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+empathy-marshal.h: empathy-marshal.list Makefile
+       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_empathy_marshal $< > empathy-marshal.h
 
-%-marshal.c: %-marshal.list Makefile
+empathy-marshal.c: empathy-marshal.list Makefile
        $(AM_V_GEN)echo "#include \"empathy-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
+       $(GLIB_GENMARSHAL) --body --prefix=_empathy_marshal $< >> empathy-marshal.c
 
 empathy-enum-types.h: stamp-empathy-enum-types.h
        $(AM_V_GEN)true