]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
build: use an autoconf macro to get to -lm
[empathy.git] / libempathy / Makefile.am
index 460026e53ea0d2ac85720c950bec73d3a5f939d2..3cd971a5d2b7e0ca0488e6163f2e91acba033465 100644 (file)
@@ -15,6 +15,7 @@ AM_CPPFLAGS =                                           \
        $(GEOCODE_CFLAGS)                               \
        $(NETWORK_MANAGER_CFLAGS)                       \
        $(CONNMAN_CFLAGS)                               \
+       $(UDEV_CFLAGS)                                  \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -31,9 +32,10 @@ libempathy_headers =                         \
        action-chain-internal.h                 \
        empathy-account-settings.h              \
        empathy-auth-factory.h                  \
-       empathy-channel-factory.h \
+       empathy-camera-monitor.h                \
        empathy-chatroom-manager.h              \
        empathy-chatroom.h                      \
+       empathy-client-factory.h \
        empathy-connection-managers.h           \
        empathy-connectivity.h                  \
        empathy-contact-groups.h                \
@@ -73,9 +75,10 @@ libempathy_handwritten_source =                              \
        action-chain.c                                  \
        empathy-account-settings.c                      \
        empathy-auth-factory.c                          \
-       empathy-channel-factory.c \
+       empathy-camera-monitor.c                        \
        empathy-chatroom-manager.c                      \
        empathy-chatroom.c                              \
+       empathy-client-factory.c \
        empathy-connection-managers.c                   \
        empathy-connectivity.c                          \
        empathy-contact-groups.c                        \
@@ -123,7 +126,9 @@ libempathy_la_LIBADD =              \
        $(GEOCLUE_LIBS) \
        $(GEOCODE_LIBS) \
        $(NETWORK_MANAGER_LIBS) \
-       $(CONNMAN_LIBS)
+       $(CONNMAN_LIBS) \
+       $(UDEV_LIBS) \
+       $(LIBM)
 
 check_c_sources = \
     $(libempathy_handwritten_source)