]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Add simple flymake support.
[empathy.git] / libempathy / Makefile.am
index 3122342cf8571a0d160128625fe61511b0729ea6..3540c88bfab605359a7c88bbcd1661b96af4063c 100644 (file)
@@ -1,4 +1,5 @@
 include $(top_srcdir)/tools/shave.mk
+include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
        -I.                                             \
@@ -7,6 +8,7 @@ AM_CPPFLAGS =                                           \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(LIBEMPATHY_CFLAGS)                            \
+       $(GEOCLUE_CFLAGS)                               \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -33,6 +35,8 @@ libempathy_la_SOURCES =                                       \
        empathy-debug.c                                 \
        empathy-dispatcher.c                            \
        empathy-dispatch-operation.c                    \
+       empathy-ft-factory.c                            \
+       empathy-ft-handler.c                            \
        empathy-idle.c                                  \
        empathy-irc-network.c                           \
        empathy-irc-network-manager.c                   \
@@ -59,7 +63,8 @@ nodist_libempathy_la_SOURCES =\
 
 libempathy_la_LIBADD =         \
        $(top_builddir)/extensions/libemp-extensions.la \
-       $(LIBEMPATHY_LIBS)
+       $(LIBEMPATHY_LIBS) \
+       $(GEOCLUE_LIBS)
 
 libempathy_la_LDFLAGS =                \
        -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE} \
@@ -79,6 +84,8 @@ libempathy_headers =                          \
        empathy-debug.h                         \
        empathy-dispatcher.h                    \
        empathy-dispatch-operation.h            \
+       empathy-ft-factory.h                    \
+       empathy-ft-handler.h                    \
        empathy-idle.h                          \
        empathy-irc-network.h                   \
        empathy-irc-network-manager.h           \
@@ -101,6 +108,12 @@ libempathy_headers =                               \
        empathy-types.h                         \
        empathy-utils.h
 
+check_c_sources = \
+    $(libempathy_la_SOURCES) \
+    $(libempathy_headers)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
 libempathy_includedir = $(includedir)/libempathy/
 libempathy_include_HEADERS =                   \
        $(libempathy_headers)                   \