]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Use the telepathy-account-widgets submodule instead of the internal copy
[empathy.git] / libempathy-gtk / Makefile.am
index 72c27b4b24b1c05e997eb93262a45c4ba506fbc1..bd83eef6409716a78e70c992d4a5391cd3005350 100644 (file)
@@ -10,6 +10,7 @@ AM_CPPFLAGS =                                           \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(TPAW_CFLAGS)                                  \
        $(YELL_CFLAGS)                                  \
        $(ENCHANT_CFLAGS)                               \
        $(LIBCHAMPLAIN_CFLAGS)                          \
@@ -22,23 +23,15 @@ AM_CPPFLAGS =                                           \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
-       empathy-account-widgets-resources.c             \
-       empathy-account-widgets-resources.h             \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
        empathy-account-selector-dialog.c               \
-       empathy-account-widget-irc.c            \
-       empathy-account-widget-private.h        \
-       empathy-account-widget-sip.c            \
-       empathy-account-widget.c                \
-       empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
        empathy-bad-password-dialog.c           \
        empathy-base-password-dialog.c          \
-       empathy-calendar-button.c \
        empathy-call-utils.c                    \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
@@ -46,8 +39,6 @@ libempathy_gtk_handwritten_source =                   \
        empathy-chat.c                          \
        empathy-contact-blocking-dialog.c       \
        empathy-contact-chooser.c               \
-       empathy-contactinfo-utils.c             \
-       empathy-live-search.c                   \
        empathy-contact-search-dialog.c         \
        empathy-contact-widget.c                \
        empathy-dialpad-widget.c                \
@@ -64,9 +55,6 @@ libempathy_gtk_handwritten_source =                   \
        empathy-individual-view.c               \
        empathy-individual-widget.c             \
        empathy-input-text-view.c               \
-       empathy-irc-network-chooser.c \
-       empathy-irc-network-chooser-dialog.c \
-       empathy-irc-network-dialog.c            \
        empathy-local-xmpp-assistant-widget.c \
        empathy-log-window.c                    \
        empathy-new-account-dialog.c            \
@@ -93,7 +81,6 @@ libempathy_gtk_handwritten_source =                   \
        empathy-theme-manager.c                 \
        empathy-tls-dialog.c                    \
        empathy-ui-utils.c                      \
-       empathy-user-info.c                     \
        empathy-plist.c                         \
        empathy-theme-adium.c                   \
        empathy-webkit-utils.c                  \
@@ -102,14 +89,9 @@ libempathy_gtk_handwritten_source =                 \
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
        empathy-account-selector-dialog.h               \
-       empathy-account-widget-irc.h            \
-       empathy-account-widget-sip.h            \
-       empathy-account-widget.h                \
-       empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
        empathy-bad-password-dialog.h           \
        empathy-base-password-dialog.h          \
-       empathy-calendar-button.h \
        empathy-call-utils.h                    \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
@@ -117,10 +99,8 @@ libempathy_gtk_headers =                    \
        empathy-chat.h                          \
        empathy-contact-blocking-dialog.h       \
        empathy-contact-chooser.h               \
-       empathy-live-search.h                   \
        empathy-contact-search-dialog.h         \
        empathy-contact-widget.h                \
-       empathy-contactinfo-utils.h             \
        empathy-dialpad-widget.h                \
        empathy-dialpad-button.h                \
        empathy-geometry.h                      \
@@ -136,9 +116,6 @@ libempathy_gtk_headers =                    \
        empathy-individual-view.h               \
        empathy-individual-widget.h             \
        empathy-input-text-view.h               \
-       empathy-irc-network-chooser.h \
-       empathy-irc-network-chooser-dialog.h \
-       empathy-irc-network-dialog.h            \
        empathy-local-xmpp-assistant-widget.h \
        empathy-log-window.h                    \
        empathy-new-account-dialog.h            \
@@ -165,7 +142,6 @@ libempathy_gtk_headers =                    \
        empathy-theme-manager.h                 \
        empathy-tls-dialog.h                    \
        empathy-ui-utils.h                      \
-       empathy-user-info.h                     \
        empathy-plist.h                         \
        empathy-theme-adium.h                   \
        empathy-webkit-utils.h                  \
@@ -183,7 +159,7 @@ libempathy_gtk_la_LDFLAGS = \
 libempathy_gtk_la_SOURCES =                    \
        $(libempathy_gtk_handwritten_source)    \
        $(libempathy_gtk_headers)               \
-       totem-subtitle-encoding.c totem-subtitle-encoding.h
+       $(NULL)
 
 # do not distribute generated files
 nodist_libempathy_gtk_la_SOURCES =\
@@ -192,6 +168,7 @@ nodist_libempathy_gtk_la_SOURCES =\
 libempathy_gtk_la_LIBADD =                     \
        $(EMPATHY_LIBS)                 \
        $(EMPATHY_LIBS)                 \
+       $(TPAW_LIBS)                    \
        $(GTK_LIBS)                     \
        $(LIBNOTIFY_LIBS)                       \
        $(CANBERRA_LIBS) \
@@ -272,17 +249,7 @@ empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
 
-account_widgets_resource_files = $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir=$(srcdir) $(srcdir)/empathy-account-widgets.gresource.xml)
-
-empathy-account-widgets-resources.c: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
-       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
-
-empathy-account-widgets-resources.h: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
-       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<
-
 EXTRA_DIST =                                   \
-       empathy-account-widgets.gresource.xml   \
-       $(account_widgets_ui_files)             \
        $(ui_DATA)
 
 if HAVE_GEOCLUE