]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Center the 'smiley images' inside the menu items
[empathy.git] / libempathy-gtk / Makefile.am
index c32448fa52f6faefed0e449eb209aeef36c4a0a9..8ea81d49f563b189a06320cd0a630d7aa7d440ba 100644 (file)
@@ -2,12 +2,13 @@ include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
        $(ERROR_CFLAGS)                                 \
-       -I.                                             \
-       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/libempathy                      \
+       -I$(top_srcdir)/extensions                      \
        -DDATADIR=\""$(datadir)"\"                      \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(TPAW_CFLAGS)                                  \
        $(YELL_CFLAGS)                                  \
        $(ENCHANT_CFLAGS)                               \
        $(LIBCHAMPLAIN_CFLAGS)                          \
@@ -15,7 +16,6 @@ AM_CPPFLAGS =                                           \
        $(GEOCODE_CFLAGS)                               \
        $(MEEGO_CFLAGS)                                 \
        $(CHEESE_CFLAGS)                                \
-       $(EDS_CFLAGS)                                   \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -23,16 +23,9 @@ BUILT_SOURCES =                                      \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
-noinst_LTLIBRARIES = libempathy-gtk.la
-
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
        empathy-account-selector-dialog.c               \
-       empathy-account-widget-irc.c            \
-       empathy-account-widget-private.h        \
-       empathy-account-widget-sip.c            \
-       empathy-account-widget.c                \
-       empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
        empathy-bad-password-dialog.c           \
        empathy-base-password-dialog.c          \
@@ -40,21 +33,18 @@ libempathy_gtk_handwritten_source =                 \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
        empathy-cell-renderer-text.c            \
-       empathy-chat-text-view.c                \
-       empathy-chat-view.c                     \
        empathy-chat.c                          \
        empathy-contact-blocking-dialog.c       \
-       empathy-contact-dialogs.c               \
        empathy-contact-chooser.c               \
-       empathy-contactinfo-utils.c             \
-       empathy-live-search.c                   \
        empathy-contact-search-dialog.c         \
        empathy-contact-widget.c                \
        empathy-dialpad-widget.c                \
+       empathy-dialpad-button.c                \
        empathy-geometry.c                      \
        empathy-groups-widget.c                 \
        empathy-individual-dialogs.c            \
        empathy-individual-edit-dialog.c        \
+       empathy-individual-information-dialog.c \
        empathy-individual-menu.c               \
        empathy-individual-store.c              \
        empathy-individual-store-channel.c              \
@@ -62,9 +52,6 @@ libempathy_gtk_handwritten_source =                   \
        empathy-individual-view.c               \
        empathy-individual-widget.c             \
        empathy-input-text-view.c               \
-       empathy-irc-network-chooser.c \
-       empathy-irc-network-chooser-dialog.c \
-       empathy-irc-network-dialog.c            \
        empathy-local-xmpp-assistant-widget.c \
        empathy-log-window.c                    \
        empathy-new-account-dialog.c            \
@@ -74,6 +61,12 @@ libempathy_gtk_handwritten_source =                  \
        empathy-password-dialog.c               \
        empathy-presence-chooser.c              \
        empathy-protocol-chooser.c              \
+       empathy-roster-contact.c                        \
+       empathy-roster-group.c                  \
+       empathy-roster-model.c                  \
+       empathy-roster-model-aggregator.c                       \
+       empathy-roster-model-manager.c                  \
+       empathy-roster-view.c                   \
        empathy-search-bar.c                    \
        empathy-share-my-desktop.c              \
        empathy-smiley-manager.c                \
@@ -81,8 +74,7 @@ libempathy_gtk_handwritten_source =                   \
        empathy-spell.c                         \
        empathy-status-preset-dialog.c          \
        empathy-string-parser.c                 \
-       empathy-theme-boxes.c                   \
-       empathy-theme-irc.c                     \
+       empathy-subscription-dialog.c   \
        empathy-theme-manager.c                 \
        empathy-tls-dialog.c                    \
        empathy-ui-utils.c                      \
@@ -94,10 +86,6 @@ libempathy_gtk_handwritten_source =                  \
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
        empathy-account-selector-dialog.h               \
-       empathy-account-widget-irc.h            \
-       empathy-account-widget-sip.h            \
-       empathy-account-widget.h                \
-       empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
        empathy-bad-password-dialog.h           \
        empathy-base-password-dialog.h          \
@@ -105,22 +93,19 @@ libempathy_gtk_headers =                   \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
        empathy-cell-renderer-text.h            \
-       empathy-chat-text-view.h                \
-       empathy-chat-view.h                     \
        empathy-chat.h                          \
        empathy-contact-blocking-dialog.h       \
-       empathy-contact-dialogs.h               \
        empathy-contact-chooser.h               \
-       empathy-live-search.h                   \
        empathy-contact-search-dialog.h         \
        empathy-contact-widget.h                \
-       empathy-contactinfo-utils.h             \
        empathy-dialpad-widget.h                \
+       empathy-dialpad-button.h                \
        empathy-geometry.h                      \
        empathy-groups-widget.h                 \
        empathy-images.h                        \
        empathy-individual-dialogs.h            \
        empathy-individual-edit-dialog.h        \
+       empathy-individual-information-dialog.h \
        empathy-individual-menu.h               \
        empathy-individual-store.h              \
        empathy-individual-store-channel.h              \
@@ -128,9 +113,6 @@ libempathy_gtk_headers =                    \
        empathy-individual-view.h               \
        empathy-individual-widget.h             \
        empathy-input-text-view.h               \
-       empathy-irc-network-chooser.h \
-       empathy-irc-network-chooser-dialog.h \
-       empathy-irc-network-dialog.h            \
        empathy-local-xmpp-assistant-widget.h \
        empathy-log-window.h                    \
        empathy-new-account-dialog.h            \
@@ -140,6 +122,12 @@ libempathy_gtk_headers =                   \
        empathy-password-dialog.h               \
        empathy-presence-chooser.h              \
        empathy-protocol-chooser.h              \
+       empathy-roster-contact.h                        \
+       empathy-roster-group.h                  \
+       empathy-roster-model.h                  \
+       empathy-roster-model-aggregator.h                       \
+       empathy-roster-model-manager.h                  \
+       empathy-roster-view.h                   \
        empathy-search-bar.h                    \
        empathy-share-my-desktop.h              \
        empathy-smiley-manager.h                \
@@ -147,8 +135,7 @@ libempathy_gtk_headers =                    \
        empathy-spell.h                         \
        empathy-status-preset-dialog.h          \
        empathy-string-parser.h                 \
-       empathy-theme-boxes.h                   \
-       empathy-theme-irc.h                     \
+       empathy-subscription-dialog.h   \
        empathy-theme-manager.h                 \
        empathy-tls-dialog.h                    \
        empathy-ui-utils.h                      \
@@ -157,11 +144,19 @@ libempathy_gtk_headers =                  \
        empathy-webkit-utils.h                  \
        $(NULL)
 
+pkglib_LTLIBRARIES = libempathy-gtk.la
+
+# libempathy-gtk's API is not stable and will never be, so use -release to make the
+# SONAME of the plugin library change with every Empathy release.
+libempathy_gtk_la_LDFLAGS = \
+   -no-undefined \
+   -release $(VERSION) \
+   $(NULL)
 
 libempathy_gtk_la_SOURCES =                    \
        $(libempathy_gtk_handwritten_source)    \
        $(libempathy_gtk_headers)               \
-       totem-subtitle-encoding.c totem-subtitle-encoding.h
+       $(NULL)
 
 # do not distribute generated files
 nodist_libempathy_gtk_la_SOURCES =\
@@ -170,6 +165,7 @@ nodist_libempathy_gtk_la_SOURCES =\
 libempathy_gtk_la_LIBADD =                     \
        $(EMPATHY_LIBS)                 \
        $(EMPATHY_LIBS)                 \
+       $(TPAW_LIBS)                    \
        $(GTK_LIBS)                     \
        $(LIBNOTIFY_LIBS)                       \
        $(CANBERRA_LIBS) \
@@ -180,7 +176,6 @@ libempathy_gtk_la_LIBADD =                  \
        $(GCR_LIBS)                             \
        $(MEEGO_LIBS)                           \
        $(CHEESE_LIBS)                          \
-       $(EDS_LIBS)                                     \
        $(top_builddir)/libempathy/libempathy.la
 
 check_c_sources = \
@@ -189,11 +184,7 @@ check_c_sources = \
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
-uidir = $(datadir)/empathy
-ui_DATA =                                      \
-       empathy-contact-widget.ui               \
-       empathy-contact-dialogs.ui              \
-       empathy-contact-blocking-dialog.ui      \
+account_widgets_ui_files =                     \
        empathy-account-widget-generic.ui       \
        empathy-account-widget-jabber.ui        \
        empathy-account-widget-msn.ui           \
@@ -204,6 +195,12 @@ ui_DATA =                                  \
        empathy-account-widget-yahoo.ui         \
        empathy-account-widget-groupwise.ui     \
        empathy-account-widget-aim.ui           \
+       $(NULL)
+
+uidir = $(datadir)/empathy
+ui_DATA =                                      \
+       empathy-contact-widget.ui               \
+       empathy-contact-blocking-dialog.ui      \
        empathy-status-preset-dialog.ui         \
        empathy-log-window.ui                   \
        empathy-chat.ui                         \
@@ -221,7 +218,7 @@ stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
                        --fhead "G_BEGIN_DECLS\n\n" \
                        --ftail "G_END_DECLS\n\n" \
                        --ftail "#endif /* __LIBEMPATHY_GTK_ENUM_TYPES_H__ */\n" \
-                       --fprod "#include <libempathy-gtk/@filename@>\n" \
+                       --fprod '#include "@filename@"\n' \
                        --eprod "#define EMPATHY_TYPE_@ENUMSHORT@ @enum_name@_get_type()\n" \
                        --eprod "GType @enum_name@_get_type (void);\n" \
                $(libempathy_gtk_headers) ) > xgen-gth \
@@ -248,15 +245,30 @@ empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
 
-EXTRA_DIST =                   \
+EXTRA_DIST =                                   \
        $(ui_DATA)
 
 if HAVE_GEOCLUE
+geoclue-interface.c: geoclue-interface.h
+geoclue-interface.h: Makefile.am
+       gdbus-codegen                                           \
+               --interface-prefix org.freedesktop.GeoClue2.    \
+               --c-namespace GClue                             \
+               --generate-c-code geoclue-interface             \
+               $(GEOCLUE_XML_FILE)
+
+BUILT_SOURCES += \
+       geoclue-interface.h \
+       geoclue-interface.c
+
 libempathy_gtk_handwritten_source +=           \
-       empathy-location-manager.c
+       empathy-location-manager.c \
+       empathy-geoclue-helper.c
 
 libempathy_gtk_headers +=                      \
-       empathy-location-manager.h
+       empathy-location-manager.h \
+       empathy-geoclue-helper.h
+
 else
 EXTRA_DIST +=                                  \
        empathy-location-manager.c              \