]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Center the 'smiley images' inside the menu items
[empathy.git] / libempathy-gtk / Makefile.am
index bd83eef6409716a78e70c992d4a5391cd3005350..8ea81d49f563b189a06320cd0a630d7aa7d440ba 100644 (file)
@@ -1,5 +1,3 @@
-SUBDIRS = egg-list-box
-
 include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
@@ -18,7 +16,6 @@ AM_CPPFLAGS =                                           \
        $(GEOCODE_CFLAGS)                               \
        $(MEEGO_CFLAGS)                                 \
        $(CHEESE_CFLAGS)                                \
-       $(EGGLISTBOX_CFLAGS)                                    \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -179,7 +176,6 @@ libempathy_gtk_la_LIBADD =                  \
        $(GCR_LIBS)                             \
        $(MEEGO_LIBS)                           \
        $(CHEESE_LIBS)                          \
-       $(top_builddir)/libempathy-gtk/egg-list-box/libegglistbox.la \
        $(top_builddir)/libempathy/libempathy.la
 
 check_c_sources = \
@@ -253,11 +249,26 @@ EXTRA_DIST =                                      \
        $(ui_DATA)
 
 if HAVE_GEOCLUE
+geoclue-interface.c: geoclue-interface.h
+geoclue-interface.h: Makefile.am
+       gdbus-codegen                                           \
+               --interface-prefix org.freedesktop.GeoClue2.    \
+               --c-namespace GClue                             \
+               --generate-c-code geoclue-interface             \
+               $(GEOCLUE_XML_FILE)
+
+BUILT_SOURCES += \
+       geoclue-interface.h \
+       geoclue-interface.c
+
 libempathy_gtk_handwritten_source +=           \
-       empathy-location-manager.c
+       empathy-location-manager.c \
+       empathy-geoclue-helper.c
 
 libempathy_gtk_headers +=                      \
-       empathy-location-manager.h
+       empathy-location-manager.h \
+       empathy-geoclue-helper.h
+
 else
 EXTRA_DIST +=                                  \
        empathy-location-manager.c              \