]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Center the 'smiley images' inside the menu items
[empathy.git] / libempathy-gtk / Makefile.am
index 8665917ffbd1de5431c145a829bd305c6c2ee151..8ea81d49f563b189a06320cd0a630d7aa7d440ba 100644 (file)
@@ -1,16 +1,14 @@
-SUBDIRS = egg-list-box
-
 include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
        $(ERROR_CFLAGS)                                 \
-       -I$(top_srcdir)/tp-account-widgets              \
        -I$(top_srcdir)/libempathy                      \
        -I$(top_srcdir)/extensions                      \
        -DDATADIR=\""$(datadir)"\"                      \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(TPAW_CFLAGS)                                  \
        $(YELL_CFLAGS)                                  \
        $(ENCHANT_CFLAGS)                               \
        $(LIBCHAMPLAIN_CFLAGS)                          \
@@ -18,7 +16,6 @@ AM_CPPFLAGS =                                           \
        $(GEOCODE_CFLAGS)                               \
        $(MEEGO_CFLAGS)                                 \
        $(CHEESE_CFLAGS)                                \
-       $(EGGLISTBOX_CFLAGS)                                    \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -29,7 +26,6 @@ BUILT_SOURCES =                                       \
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
        empathy-account-selector-dialog.c               \
-       empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
        empathy-bad-password-dialog.c           \
        empathy-base-password-dialog.c          \
@@ -82,7 +78,6 @@ libempathy_gtk_handwritten_source =                   \
        empathy-theme-manager.c                 \
        empathy-tls-dialog.c                    \
        empathy-ui-utils.c                      \
-       empathy-user-info.c                     \
        empathy-plist.c                         \
        empathy-theme-adium.c                   \
        empathy-webkit-utils.c                  \
@@ -91,7 +86,6 @@ libempathy_gtk_handwritten_source =                   \
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
        empathy-account-selector-dialog.h               \
-       empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
        empathy-bad-password-dialog.h           \
        empathy-base-password-dialog.h          \
@@ -145,7 +139,6 @@ libempathy_gtk_headers =                    \
        empathy-theme-manager.h                 \
        empathy-tls-dialog.h                    \
        empathy-ui-utils.h                      \
-       empathy-user-info.h                     \
        empathy-plist.h                         \
        empathy-theme-adium.h                   \
        empathy-webkit-utils.h                  \
@@ -172,6 +165,7 @@ nodist_libempathy_gtk_la_SOURCES =\
 libempathy_gtk_la_LIBADD =                     \
        $(EMPATHY_LIBS)                 \
        $(EMPATHY_LIBS)                 \
+       $(TPAW_LIBS)                    \
        $(GTK_LIBS)                     \
        $(LIBNOTIFY_LIBS)                       \
        $(CANBERRA_LIBS) \
@@ -182,8 +176,6 @@ libempathy_gtk_la_LIBADD =                  \
        $(GCR_LIBS)                             \
        $(MEEGO_LIBS)                           \
        $(CHEESE_LIBS)                          \
-       $(top_builddir)/tp-account-widgets/libtp-account-widgets.la \
-       $(top_builddir)/libempathy-gtk/egg-list-box/libegglistbox.la \
        $(top_builddir)/libempathy/libempathy.la
 
 check_c_sources = \
@@ -257,11 +249,26 @@ EXTRA_DIST =                                      \
        $(ui_DATA)
 
 if HAVE_GEOCLUE
+geoclue-interface.c: geoclue-interface.h
+geoclue-interface.h: Makefile.am
+       gdbus-codegen                                           \
+               --interface-prefix org.freedesktop.GeoClue2.    \
+               --c-namespace GClue                             \
+               --generate-c-code geoclue-interface             \
+               $(GEOCLUE_XML_FILE)
+
+BUILT_SOURCES += \
+       geoclue-interface.h \
+       geoclue-interface.c
+
 libempathy_gtk_handwritten_source +=           \
-       empathy-location-manager.c
+       empathy-location-manager.c \
+       empathy-geoclue-helper.c
 
 libempathy_gtk_headers +=                      \
-       empathy-location-manager.h
+       empathy-location-manager.h \
+       empathy-geoclue-helper.h
+
 else
 EXTRA_DIST +=                                  \
        empathy-location-manager.c              \