]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Center the 'smiley images' inside the menu items
[empathy.git] / libempathy-gtk / Makefile.am
index 72c27b4b24b1c05e997eb93262a45c4ba506fbc1..8ea81d49f563b189a06320cd0a630d7aa7d440ba 100644 (file)
@@ -1,5 +1,3 @@
-SUBDIRS = egg-list-box
-
 include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
@@ -10,6 +8,7 @@ AM_CPPFLAGS =                                           \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(TPAW_CFLAGS)                                  \
        $(YELL_CFLAGS)                                  \
        $(ENCHANT_CFLAGS)                               \
        $(LIBCHAMPLAIN_CFLAGS)                          \
@@ -17,28 +16,19 @@ AM_CPPFLAGS =                                           \
        $(GEOCODE_CFLAGS)                               \
        $(MEEGO_CFLAGS)                                 \
        $(CHEESE_CFLAGS)                                \
-       $(EGGLISTBOX_CFLAGS)                                    \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
-       empathy-account-widgets-resources.c             \
-       empathy-account-widgets-resources.h             \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
        empathy-account-selector-dialog.c               \
-       empathy-account-widget-irc.c            \
-       empathy-account-widget-private.h        \
-       empathy-account-widget-sip.c            \
-       empathy-account-widget.c                \
-       empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
        empathy-bad-password-dialog.c           \
        empathy-base-password-dialog.c          \
-       empathy-calendar-button.c \
        empathy-call-utils.c                    \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
@@ -46,8 +36,6 @@ libempathy_gtk_handwritten_source =                   \
        empathy-chat.c                          \
        empathy-contact-blocking-dialog.c       \
        empathy-contact-chooser.c               \
-       empathy-contactinfo-utils.c             \
-       empathy-live-search.c                   \
        empathy-contact-search-dialog.c         \
        empathy-contact-widget.c                \
        empathy-dialpad-widget.c                \
@@ -64,9 +52,6 @@ libempathy_gtk_handwritten_source =                   \
        empathy-individual-view.c               \
        empathy-individual-widget.c             \
        empathy-input-text-view.c               \
-       empathy-irc-network-chooser.c \
-       empathy-irc-network-chooser-dialog.c \
-       empathy-irc-network-dialog.c            \
        empathy-local-xmpp-assistant-widget.c \
        empathy-log-window.c                    \
        empathy-new-account-dialog.c            \
@@ -93,7 +78,6 @@ libempathy_gtk_handwritten_source =                   \
        empathy-theme-manager.c                 \
        empathy-tls-dialog.c                    \
        empathy-ui-utils.c                      \
-       empathy-user-info.c                     \
        empathy-plist.c                         \
        empathy-theme-adium.c                   \
        empathy-webkit-utils.c                  \
@@ -102,14 +86,9 @@ libempathy_gtk_handwritten_source =                 \
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
        empathy-account-selector-dialog.h               \
-       empathy-account-widget-irc.h            \
-       empathy-account-widget-sip.h            \
-       empathy-account-widget.h                \
-       empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
        empathy-bad-password-dialog.h           \
        empathy-base-password-dialog.h          \
-       empathy-calendar-button.h \
        empathy-call-utils.h                    \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
@@ -117,10 +96,8 @@ libempathy_gtk_headers =                    \
        empathy-chat.h                          \
        empathy-contact-blocking-dialog.h       \
        empathy-contact-chooser.h               \
-       empathy-live-search.h                   \
        empathy-contact-search-dialog.h         \
        empathy-contact-widget.h                \
-       empathy-contactinfo-utils.h             \
        empathy-dialpad-widget.h                \
        empathy-dialpad-button.h                \
        empathy-geometry.h                      \
@@ -136,9 +113,6 @@ libempathy_gtk_headers =                    \
        empathy-individual-view.h               \
        empathy-individual-widget.h             \
        empathy-input-text-view.h               \
-       empathy-irc-network-chooser.h \
-       empathy-irc-network-chooser-dialog.h \
-       empathy-irc-network-dialog.h            \
        empathy-local-xmpp-assistant-widget.h \
        empathy-log-window.h                    \
        empathy-new-account-dialog.h            \
@@ -165,7 +139,6 @@ libempathy_gtk_headers =                    \
        empathy-theme-manager.h                 \
        empathy-tls-dialog.h                    \
        empathy-ui-utils.h                      \
-       empathy-user-info.h                     \
        empathy-plist.h                         \
        empathy-theme-adium.h                   \
        empathy-webkit-utils.h                  \
@@ -183,7 +156,7 @@ libempathy_gtk_la_LDFLAGS = \
 libempathy_gtk_la_SOURCES =                    \
        $(libempathy_gtk_handwritten_source)    \
        $(libempathy_gtk_headers)               \
-       totem-subtitle-encoding.c totem-subtitle-encoding.h
+       $(NULL)
 
 # do not distribute generated files
 nodist_libempathy_gtk_la_SOURCES =\
@@ -192,6 +165,7 @@ nodist_libempathy_gtk_la_SOURCES =\
 libempathy_gtk_la_LIBADD =                     \
        $(EMPATHY_LIBS)                 \
        $(EMPATHY_LIBS)                 \
+       $(TPAW_LIBS)                    \
        $(GTK_LIBS)                     \
        $(LIBNOTIFY_LIBS)                       \
        $(CANBERRA_LIBS) \
@@ -202,7 +176,6 @@ libempathy_gtk_la_LIBADD =                  \
        $(GCR_LIBS)                             \
        $(MEEGO_LIBS)                           \
        $(CHEESE_LIBS)                          \
-       $(top_builddir)/libempathy-gtk/egg-list-box/libegglistbox.la \
        $(top_builddir)/libempathy/libempathy.la
 
 check_c_sources = \
@@ -272,25 +245,30 @@ empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
 
-account_widgets_resource_files = $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir=$(srcdir) $(srcdir)/empathy-account-widgets.gresource.xml)
-
-empathy-account-widgets-resources.c: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
-       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
-
-empathy-account-widgets-resources.h: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
-       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<
-
 EXTRA_DIST =                                   \
-       empathy-account-widgets.gresource.xml   \
-       $(account_widgets_ui_files)             \
        $(ui_DATA)
 
 if HAVE_GEOCLUE
+geoclue-interface.c: geoclue-interface.h
+geoclue-interface.h: Makefile.am
+       gdbus-codegen                                           \
+               --interface-prefix org.freedesktop.GeoClue2.    \
+               --c-namespace GClue                             \
+               --generate-c-code geoclue-interface             \
+               $(GEOCLUE_XML_FILE)
+
+BUILT_SOURCES += \
+       geoclue-interface.h \
+       geoclue-interface.c
+
 libempathy_gtk_handwritten_source +=           \
-       empathy-location-manager.c
+       empathy-location-manager.c \
+       empathy-geoclue-helper.c
 
 libempathy_gtk_headers +=                      \
-       empathy-location-manager.h
+       empathy-location-manager.h \
+       empathy-geoclue-helper.h
+
 else
 EXTRA_DIST +=                                  \
        empathy-location-manager.c              \