]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
sort contacts by most recent event
[empathy.git] / libempathy-gtk / Makefile.am
index 6cc6c09927d765c5d03aefe5f36c099b39a8757f..8ea81d49f563b189a06320cd0a630d7aa7d440ba 100644 (file)
@@ -2,160 +2,161 @@ include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
        $(ERROR_CFLAGS)                                 \
-       -I.                                             \
-       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/libempathy                      \
+       -I$(top_srcdir)/extensions                      \
        -DDATADIR=\""$(datadir)"\"                      \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
-       $(GTK_CFLAGS)                           \
-       $(LIBNOTIFY_CFLAGS)                             \
-       $(CANBERRA_CFLAGS) \
+       $(TPAW_CFLAGS)                                  \
+       $(YELL_CFLAGS)                                  \
        $(ENCHANT_CFLAGS)                               \
        $(LIBCHAMPLAIN_CFLAGS)                          \
        $(GEOCLUE_CFLAGS)                               \
-       $(GCR_CFLAGS)                                   \
-       $(MEEGO_CFLAGS)                         \
-       $(WEBKIT_CFLAGS)                                \
+       $(GEOCODE_CFLAGS)                               \
+       $(MEEGO_CFLAGS)                                 \
+       $(CHEESE_CFLAGS)                                \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
-       empathy-gtk-marshal.h                           \
-       empathy-gtk-marshal.c                           \
-       empathy-gtk-marshal.list                        \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
-noinst_LTLIBRARIES = libempathy-gtk.la
-
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
-       empathy-account-widget-irc.c            \
-       empathy-account-widget-private.h        \
-       empathy-account-widget-sip.c            \
-       empathy-account-widget.c                \
-       empathy-audio-sink.c                    \
-       empathy-audio-src.c                     \
-       empathy-avatar-chooser.c                \
+       empathy-account-selector-dialog.c               \
        empathy-avatar-image.c                  \
+       empathy-bad-password-dialog.c           \
+       empathy-base-password-dialog.c          \
+       empathy-call-utils.c                    \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
        empathy-cell-renderer-text.c            \
-       empathy-chat-text-view.c                \
-       empathy-chat-view.c                     \
        empathy-chat.c                          \
-       empathy-contact-dialogs.c               \
-       empathy-contact-list-store.c            \
-       empathy-contact-list-view.c             \
-       empathy-contact-menu.c                  \
-       empathy-linking-dialog.c                \
-       empathy-live-search.c                   \
-       empathy-contact-selector.c              \
-       empathy-contact-selector-dialog.c \
+       empathy-contact-blocking-dialog.c       \
+       empathy-contact-chooser.c               \
+       empathy-contact-search-dialog.c         \
        empathy-contact-widget.c                \
+       empathy-dialpad-widget.c                \
+       empathy-dialpad-button.c                \
        empathy-geometry.c                      \
        empathy-groups-widget.c                 \
        empathy-individual-dialogs.c            \
        empathy-individual-edit-dialog.c        \
        empathy-individual-information-dialog.c \
-       empathy-individual-linker.c             \
        empathy-individual-menu.c               \
        empathy-individual-store.c              \
+       empathy-individual-store-channel.c              \
+       empathy-individual-store-manager.c              \
        empathy-individual-view.c               \
        empathy-individual-widget.c             \
-       empathy-irc-network-chooser.c \
-       empathy-irc-network-chooser-dialog.c \
-       empathy-irc-network-dialog.c            \
+       empathy-input-text-view.c               \
+       empathy-local-xmpp-assistant-widget.c \
        empathy-log-window.c                    \
+       empathy-new-account-dialog.c            \
        empathy-new-message-dialog.c            \
        empathy-new-call-dialog.c               \
        empathy-notify-manager.c                \
-       empathy-persona-store.c                 \
-       empathy-persona-view.c                  \
+       empathy-password-dialog.c               \
        empathy-presence-chooser.c              \
        empathy-protocol-chooser.c              \
+       empathy-roster-contact.c                        \
+       empathy-roster-group.c                  \
+       empathy-roster-model.c                  \
+       empathy-roster-model-aggregator.c                       \
+       empathy-roster-model-manager.c                  \
+       empathy-roster-view.c                   \
        empathy-search-bar.c                    \
        empathy-share-my-desktop.c              \
        empathy-smiley-manager.c                \
-       empathy-sound.c                         \
+       empathy-sound-manager.c                 \
        empathy-spell.c                         \
        empathy-status-preset-dialog.c          \
        empathy-string-parser.c                 \
-       empathy-theme-boxes.c                   \
-       empathy-theme-irc.c                     \
+       empathy-subscription-dialog.c   \
        empathy-theme-manager.c                 \
        empathy-tls-dialog.c                    \
        empathy-ui-utils.c                      \
-       empathy-video-src.c                     \
-       empathy-video-widget.c
+       empathy-plist.c                         \
+       empathy-theme-adium.c                   \
+       empathy-webkit-utils.c                  \
+       $(NULL)
 
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
-       empathy-account-widget-irc.h            \
-       empathy-account-widget-sip.h            \
-       empathy-account-widget.h                \
-       empathy-audio-sink.h                    \
-       empathy-audio-src.h                     \
-       empathy-avatar-chooser.h                \
+       empathy-account-selector-dialog.h               \
        empathy-avatar-image.h                  \
+       empathy-bad-password-dialog.h           \
+       empathy-base-password-dialog.h          \
+       empathy-call-utils.h                    \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
        empathy-cell-renderer-text.h            \
-       empathy-chat-text-view.h                \
-       empathy-chat-view.h                     \
        empathy-chat.h                          \
-       empathy-contact-dialogs.h               \
-       empathy-contact-list-store.h            \
-       empathy-contact-list-view.h             \
-       empathy-contact-menu.h                  \
-       empathy-linking-dialog.h                \
-       empathy-live-search.h                   \
-       empathy-contact-selector.h              \
-       empathy-contact-selector-dialog.h \
+       empathy-contact-blocking-dialog.h       \
+       empathy-contact-chooser.h               \
+       empathy-contact-search-dialog.h         \
        empathy-contact-widget.h                \
+       empathy-dialpad-widget.h                \
+       empathy-dialpad-button.h                \
        empathy-geometry.h                      \
        empathy-groups-widget.h                 \
        empathy-images.h                        \
        empathy-individual-dialogs.h            \
        empathy-individual-edit-dialog.h        \
        empathy-individual-information-dialog.h \
-       empathy-individual-linker.h             \
        empathy-individual-menu.h               \
        empathy-individual-store.h              \
+       empathy-individual-store-channel.h              \
+       empathy-individual-store-manager.h              \
        empathy-individual-view.h               \
        empathy-individual-widget.h             \
-       empathy-irc-network-chooser.h \
-       empathy-irc-network-chooser-dialog.h \
-       empathy-irc-network-dialog.h            \
+       empathy-input-text-view.h               \
+       empathy-local-xmpp-assistant-widget.h \
        empathy-log-window.h                    \
+       empathy-new-account-dialog.h            \
        empathy-new-message-dialog.h            \
        empathy-new-call-dialog.h               \
        empathy-notify-manager.h                \
-       empathy-persona-store.h                 \
-       empathy-persona-view.h                  \
+       empathy-password-dialog.h               \
        empathy-presence-chooser.h              \
        empathy-protocol-chooser.h              \
+       empathy-roster-contact.h                        \
+       empathy-roster-group.h                  \
+       empathy-roster-model.h                  \
+       empathy-roster-model-aggregator.h                       \
+       empathy-roster-model-manager.h                  \
+       empathy-roster-view.h                   \
        empathy-search-bar.h                    \
        empathy-share-my-desktop.h              \
        empathy-smiley-manager.h                \
-       empathy-sound.h                         \
+       empathy-sound-manager.h                 \
        empathy-spell.h                         \
        empathy-status-preset-dialog.h          \
        empathy-string-parser.h                 \
-       empathy-theme-boxes.h                   \
-       empathy-theme-irc.h                     \
+       empathy-subscription-dialog.h   \
        empathy-theme-manager.h                 \
        empathy-tls-dialog.h                    \
        empathy-ui-utils.h                      \
-       empathy-video-src.h                     \
-       empathy-video-widget.h
+       empathy-plist.h                         \
+       empathy-theme-adium.h                   \
+       empathy-webkit-utils.h                  \
+       $(NULL)
+
+pkglib_LTLIBRARIES = libempathy-gtk.la
+
+# libempathy-gtk's API is not stable and will never be, so use -release to make the
+# SONAME of the plugin library change with every Empathy release.
+libempathy_gtk_la_LDFLAGS = \
+   -no-undefined \
+   -release $(VERSION) \
+   $(NULL)
 
 libempathy_gtk_la_SOURCES =                    \
        $(libempathy_gtk_handwritten_source)    \
        $(libempathy_gtk_headers)               \
-       gcr-simple-certificate.c gcr-simple-certificate.h \
-       totem-subtitle-encoding.c totem-subtitle-encoding.h
+       $(NULL)
 
 # do not distribute generated files
 nodist_libempathy_gtk_la_SOURCES =\
@@ -163,15 +164,18 @@ nodist_libempathy_gtk_la_SOURCES =\
 
 libempathy_gtk_la_LIBADD =                     \
        $(EMPATHY_LIBS)                 \
+       $(EMPATHY_LIBS)                 \
+       $(TPAW_LIBS)                    \
        $(GTK_LIBS)                     \
        $(LIBNOTIFY_LIBS)                       \
        $(CANBERRA_LIBS) \
        $(ENCHANT_LIBS)                         \
        $(LIBCHAMPLAIN_LIBS)                    \
        $(GEOCLUE_LIBS)                         \
+       $(GEOCODE_LIBS)                         \
        $(GCR_LIBS)                             \
        $(MEEGO_LIBS)                           \
-       $(WEBKIT_LIBS)                          \
+       $(CHEESE_LIBS)                          \
        $(top_builddir)/libempathy/libempathy.la
 
 check_c_sources = \
@@ -180,10 +184,7 @@ check_c_sources = \
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
-uidir = $(datadir)/empathy
-ui_DATA =                                      \
-       empathy-contact-widget.ui               \
-       empathy-contact-dialogs.ui              \
+account_widgets_ui_files =                     \
        empathy-account-widget-generic.ui       \
        empathy-account-widget-jabber.ui        \
        empathy-account-widget-msn.ui           \
@@ -194,31 +195,18 @@ ui_DATA =                                         \
        empathy-account-widget-yahoo.ui         \
        empathy-account-widget-groupwise.ui     \
        empathy-account-widget-aim.ui           \
+       $(NULL)
+
+uidir = $(datadir)/empathy
+ui_DATA =                                      \
+       empathy-contact-widget.ui               \
+       empathy-contact-blocking-dialog.ui      \
        empathy-status-preset-dialog.ui         \
        empathy-log-window.ui                   \
        empathy-chat.ui                         \
-       empathy-contact-selector-dialog.ui      \
        empathy-search-bar.ui                   \
        empathy-individual-widget.ui
 
-empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
-       $(AM_V_GEN)( cd $(srcdir) && \
-       sed -n -e 's/.*empathy_gtk_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
-       $(libempathy_gtk_la_SOURCES) ) \
-       | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       @if cmp -s $@.tmp $@; then \
-               rm $@.tmp; \
-       else \
-               mv $@.tmp $@; \
-       fi
-
-%-marshal.h: %-marshal.list Makefile
-       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
-
-%-marshal.c: %-marshal.list Makefile
-       $(AM_V_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
-
 empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
        $(AM_V_GEN)true
 stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
@@ -230,7 +218,7 @@ stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
                        --fhead "G_BEGIN_DECLS\n\n" \
                        --ftail "G_END_DECLS\n\n" \
                        --ftail "#endif /* __LIBEMPATHY_GTK_ENUM_TYPES_H__ */\n" \
-                       --fprod "#include <libempathy-gtk/@filename@>\n" \
+                       --fprod '#include "@filename@"\n' \
                        --eprod "#define EMPATHY_TYPE_@ENUMSHORT@ @enum_name@_get_type()\n" \
                        --eprod "GType @enum_name@_get_type (void);\n" \
                $(libempathy_gtk_headers) ) > xgen-gth \
@@ -257,36 +245,36 @@ empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
 
-EXTRA_DIST =                   \
+EXTRA_DIST =                                   \
        $(ui_DATA)
 
 if HAVE_GEOCLUE
+geoclue-interface.c: geoclue-interface.h
+geoclue-interface.h: Makefile.am
+       gdbus-codegen                                           \
+               --interface-prefix org.freedesktop.GeoClue2.    \
+               --c-namespace GClue                             \
+               --generate-c-code geoclue-interface             \
+               $(GEOCLUE_XML_FILE)
+
+BUILT_SOURCES += \
+       geoclue-interface.h \
+       geoclue-interface.c
+
 libempathy_gtk_handwritten_source +=           \
-       empathy-location-manager.c
+       empathy-location-manager.c \
+       empathy-geoclue-helper.c
 
 libempathy_gtk_headers +=                      \
-       empathy-location-manager.h
+       empathy-location-manager.h \
+       empathy-geoclue-helper.h
+
 else
 EXTRA_DIST +=                                  \
        empathy-location-manager.c              \
        empathy-location-manager.h
 endif
 
-if HAVE_WEBKIT
-libempathy_gtk_handwritten_source +=           \
-       empathy-plist.c                         \
-       empathy-theme-adium.c
-libempathy_gtk_headers +=                      \
-       empathy-plist.h                         \
-       empathy-theme-adium.h
-else
-EXTRA_DIST +=                                  \
-       empathy-plist.c                         \
-       empathy-plist.h                         \
-       empathy-theme-adium.c                   \
-       empathy-theme-adium.h
-endif
-
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \
        stamp-empathy-gtk-enum-types.h