]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
GNOME Goal: Update icon names
[empathy.git] / libempathy-gtk / Makefile.am
index 7a9d01dfa7b2c2c5aeaf7ac32c8e9f245764d837..72c27b4b24b1c05e997eb93262a45c4ba506fbc1 100644 (file)
@@ -4,8 +4,8 @@ include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
        $(ERROR_CFLAGS)                                 \
-       -I.                                             \
-       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/libempathy                      \
+       -I$(top_srcdir)/extensions                      \
        -DDATADIR=\""$(datadir)"\"                      \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
@@ -22,11 +22,11 @@ AM_CPPFLAGS =                                           \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
+       empathy-account-widgets-resources.c             \
+       empathy-account-widgets-resources.h             \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
-noinst_LTLIBRARIES = libempathy-gtk.la
-
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
        empathy-account-selector-dialog.c               \
@@ -43,17 +43,15 @@ libempathy_gtk_handwritten_source =                 \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
        empathy-cell-renderer-text.c            \
-       empathy-chat-text-view.c                \
-       empathy-chat-view.c                     \
        empathy-chat.c                          \
        empathy-contact-blocking-dialog.c       \
-       empathy-contact-dialogs.c               \
        empathy-contact-chooser.c               \
        empathy-contactinfo-utils.c             \
        empathy-live-search.c                   \
        empathy-contact-search-dialog.c         \
        empathy-contact-widget.c                \
        empathy-dialpad-widget.c                \
+       empathy-dialpad-button.c                \
        empathy-geometry.c                      \
        empathy-groups-widget.c                 \
        empathy-individual-dialogs.c            \
@@ -79,6 +77,10 @@ libempathy_gtk_handwritten_source =                  \
        empathy-presence-chooser.c              \
        empathy-protocol-chooser.c              \
        empathy-roster-contact.c                        \
+       empathy-roster-group.c                  \
+       empathy-roster-model.c                  \
+       empathy-roster-model-aggregator.c                       \
+       empathy-roster-model-manager.c                  \
        empathy-roster-view.c                   \
        empathy-search-bar.c                    \
        empathy-share-my-desktop.c              \
@@ -87,11 +89,11 @@ libempathy_gtk_handwritten_source =                 \
        empathy-spell.c                         \
        empathy-status-preset-dialog.c          \
        empathy-string-parser.c                 \
-       empathy-theme-boxes.c                   \
-       empathy-theme-irc.c                     \
+       empathy-subscription-dialog.c   \
        empathy-theme-manager.c                 \
        empathy-tls-dialog.c                    \
        empathy-ui-utils.c                      \
+       empathy-user-info.c                     \
        empathy-plist.c                         \
        empathy-theme-adium.c                   \
        empathy-webkit-utils.c                  \
@@ -112,17 +114,15 @@ libempathy_gtk_headers =                  \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
        empathy-cell-renderer-text.h            \
-       empathy-chat-text-view.h                \
-       empathy-chat-view.h                     \
        empathy-chat.h                          \
        empathy-contact-blocking-dialog.h       \
-       empathy-contact-dialogs.h               \
        empathy-contact-chooser.h               \
        empathy-live-search.h                   \
        empathy-contact-search-dialog.h         \
        empathy-contact-widget.h                \
        empathy-contactinfo-utils.h             \
        empathy-dialpad-widget.h                \
+       empathy-dialpad-button.h                \
        empathy-geometry.h                      \
        empathy-groups-widget.h                 \
        empathy-images.h                        \
@@ -149,6 +149,10 @@ libempathy_gtk_headers =                   \
        empathy-presence-chooser.h              \
        empathy-protocol-chooser.h              \
        empathy-roster-contact.h                        \
+       empathy-roster-group.h                  \
+       empathy-roster-model.h                  \
+       empathy-roster-model-aggregator.h                       \
+       empathy-roster-model-manager.h                  \
        empathy-roster-view.h                   \
        empathy-search-bar.h                    \
        empathy-share-my-desktop.h              \
@@ -157,16 +161,24 @@ libempathy_gtk_headers =                  \
        empathy-spell.h                         \
        empathy-status-preset-dialog.h          \
        empathy-string-parser.h                 \
-       empathy-theme-boxes.h                   \
-       empathy-theme-irc.h                     \
+       empathy-subscription-dialog.h   \
        empathy-theme-manager.h                 \
        empathy-tls-dialog.h                    \
        empathy-ui-utils.h                      \
+       empathy-user-info.h                     \
        empathy-plist.h                         \
        empathy-theme-adium.h                   \
        empathy-webkit-utils.h                  \
        $(NULL)
 
+pkglib_LTLIBRARIES = libempathy-gtk.la
+
+# libempathy-gtk's API is not stable and will never be, so use -release to make the
+# SONAME of the plugin library change with every Empathy release.
+libempathy_gtk_la_LDFLAGS = \
+   -no-undefined \
+   -release $(VERSION) \
+   $(NULL)
 
 libempathy_gtk_la_SOURCES =                    \
        $(libempathy_gtk_handwritten_source)    \
@@ -199,11 +211,7 @@ check_c_sources = \
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
-uidir = $(datadir)/empathy
-ui_DATA =                                      \
-       empathy-contact-widget.ui               \
-       empathy-contact-dialogs.ui              \
-       empathy-contact-blocking-dialog.ui      \
+account_widgets_ui_files =                     \
        empathy-account-widget-generic.ui       \
        empathy-account-widget-jabber.ui        \
        empathy-account-widget-msn.ui           \
@@ -214,6 +222,12 @@ ui_DATA =                                  \
        empathy-account-widget-yahoo.ui         \
        empathy-account-widget-groupwise.ui     \
        empathy-account-widget-aim.ui           \
+       $(NULL)
+
+uidir = $(datadir)/empathy
+ui_DATA =                                      \
+       empathy-contact-widget.ui               \
+       empathy-contact-blocking-dialog.ui      \
        empathy-status-preset-dialog.ui         \
        empathy-log-window.ui                   \
        empathy-chat.ui                         \
@@ -231,7 +245,7 @@ stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
                        --fhead "G_BEGIN_DECLS\n\n" \
                        --ftail "G_END_DECLS\n\n" \
                        --ftail "#endif /* __LIBEMPATHY_GTK_ENUM_TYPES_H__ */\n" \
-                       --fprod "#include <libempathy-gtk/@filename@>\n" \
+                       --fprod '#include "@filename@"\n' \
                        --eprod "#define EMPATHY_TYPE_@ENUMSHORT@ @enum_name@_get_type()\n" \
                        --eprod "GType @enum_name@_get_type (void);\n" \
                $(libempathy_gtk_headers) ) > xgen-gth \
@@ -258,7 +272,17 @@ empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
 
-EXTRA_DIST =                   \
+account_widgets_resource_files = $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir=$(srcdir) $(srcdir)/empathy-account-widgets.gresource.xml)
+
+empathy-account-widgets-resources.c: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
+
+empathy-account-widgets-resources.h: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<
+
+EXTRA_DIST =                                   \
+       empathy-account-widgets.gresource.xml   \
+       $(account_widgets_ui_files)             \
        $(ui_DATA)
 
 if HAVE_GEOCLUE