]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Updated Polish translation
[empathy.git] / libempathy-gtk / Makefile.am
index 2f1eaaa253c113a441576414cc20721dd52dfd60..6ec319e1ca5469009d14a6f19ee81330ade72dc3 100644 (file)
@@ -1,14 +1,19 @@
-include $(top_srcdir)/tools/shave.mk
+include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
+       $(ERROR_CFLAGS)                                 \
        -I.                                             \
        -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(LIBEMPATHYGTK_CFLAGS)                         \
+       $(TPL_CFLAGS)                                   \
+       $(LIBNOTIFY_CFLAGS)                             \
        $(ENCHANT_CFLAGS)                               \
-       $(GEOCLUE_CFLAGS)                               \
        $(LIBCHAMPLAIN_CFLAGS)                          \
+       $(GEOCLUE_CFLAGS)                               \
+       $(MEEGO_CFLAGS)                         \
+       $(WEBKIT_CFLAGS)                                \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -19,103 +24,121 @@ BUILT_SOURCES =                                   \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
-lib_LTLIBRARIES = libempathy-gtk.la
+noinst_LTLIBRARIES = libempathy-gtk.la
 
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
-       empathy-account-widget.c                \
        empathy-account-widget-irc.c            \
+       empathy-account-widget-private.h        \
        empathy-account-widget-sip.c            \
+       empathy-account-widget.c                \
+       empathy-audio-sink.c                    \
+       empathy-audio-src.c                     \
        empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
        empathy-cell-renderer-text.c            \
-       empathy-chat.c                          \
        empathy-chat-text-view.c                \
        empathy-chat-view.c                     \
+       empathy-chat.c                          \
        empathy-conf.c                          \
        empathy-contact-dialogs.c               \
        empathy-contact-list-store.c            \
        empathy-contact-list-view.c             \
        empathy-contact-menu.c                  \
        empathy-contact-selector.c              \
+       empathy-contact-selector-dialog.c \
        empathy-contact-widget.c                \
        empathy-geometry.c                      \
-       empathy-audio-sink.c                    \
-       empathy-audio-src.c                     \
-       empathy-video-src.c                     \
-       empathy-video-widget.c                  \
        empathy-irc-network-dialog.c            \
+       empathy-kludge-label.c                  \
        empathy-log-window.c                    \
        empathy-new-message-dialog.c            \
+       empathy-new-call-dialog.c               \
+       empathy-notify-manager.c                \
        empathy-presence-chooser.c              \
-       empathy-profile-chooser.c               \
+       empathy-protocol-chooser.c              \
+       empathy-search-bar.c                    \
+       empathy-share-my-desktop.c              \
        empathy-smiley-manager.c                \
+       empathy-sound.c                         \
        empathy-spell.c                         \
        empathy-status-preset-dialog.c          \
+       empathy-string-parser.c                 \
        empathy-theme-boxes.c                   \
        empathy-theme-irc.c                     \
        empathy-theme-manager.c                 \
-       empathy-ui-utils.c
-
-libempathy_gtk_la_SOURCES =                    \
-       $(libempathy_gtk_handwritten_source)    \
-       totem-subtitle-encoding.c totem-subtitle-encoding.h
-
-# do not distribute generated files
-nodist_libempathy_gtk_la_SOURCES =\
-       $(BUILT_SOURCES)
-
-libempathy_gtk_la_LIBADD =                     \
-       $(LIBEMPATHYGTK_LIBS)                   \
-       $(ENCHANT_LIBS)                         \
-       $(GEOCLUE_LIBS)                         \
-       $(LIBCHAMPLAIN_LIBS)                    \
-       $(top_builddir)/libempathy/libempathy.la
-
-libempathy_gtk_la_LDFLAGS =                \
-       -version-info ${LIBEMPATHY_GTK_CURRENT}:${LIBEMPATHY_GTK_REVISION}:${LIBEMPATHY_GTK_AGE} \
-       -export-symbols-regex ^empathy_
+       empathy-ui-utils.c                      \
+       empathy-video-src.c                     \
+       empathy-video-widget.c
 
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
-       empathy-account-widget.h                \
        empathy-account-widget-irc.h            \
        empathy-account-widget-sip.h            \
+       empathy-account-widget.h                \
+       empathy-audio-sink.h                    \
+       empathy-audio-src.h                     \
        empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
        empathy-cell-renderer-text.h            \
-       empathy-chat.h                          \
        empathy-chat-text-view.h                \
        empathy-chat-view.h                     \
+       empathy-chat.h                          \
        empathy-conf.h                          \
        empathy-contact-dialogs.h               \
        empathy-contact-list-store.h            \
        empathy-contact-list-view.h             \
        empathy-contact-menu.h                  \
        empathy-contact-selector.h              \
+       empathy-contact-selector-dialog.h \
        empathy-contact-widget.h                \
        empathy-geometry.h                      \
-       empathy-audio-sink.h                    \
-       empathy-audio-src.h                     \
-       empathy-video-src.h                     \
-       empathy-video-widget.h                  \
        empathy-images.h                        \
        empathy-irc-network-dialog.h            \
+       empathy-kludge-label.h                  \
        empathy-log-window.h                    \
        empathy-new-message-dialog.h            \
+       empathy-new-call-dialog.h               \
+       empathy-notify-manager.h                \
        empathy-presence-chooser.h              \
-       empathy-profile-chooser.h               \
+       empathy-protocol-chooser.h              \
+       empathy-search-bar.h                    \
+       empathy-share-my-desktop.h              \
        empathy-smiley-manager.h                \
+       empathy-sound.h                         \
        empathy-spell.h                         \
        empathy-status-preset-dialog.h          \
+       empathy-string-parser.h                 \
        empathy-theme-boxes.h                   \
        empathy-theme-irc.h                     \
        empathy-theme-manager.h                 \
-       empathy-ui-utils.h
+       empathy-ui-utils.h                      \
+       empathy-video-src.h                     \
+       empathy-video-widget.h
+
+libempathy_gtk_la_SOURCES =                    \
+       $(libempathy_gtk_handwritten_source)    \
+       $(libempathy_gtk_headers)               \
+       totem-subtitle-encoding.c totem-subtitle-encoding.h
+
+# do not distribute generated files
+nodist_libempathy_gtk_la_SOURCES =\
+       $(BUILT_SOURCES)
+
+libempathy_gtk_la_LIBADD =                     \
+       $(LIBEMPATHYGTK_LIBS)                   \
+       $(LIBNOTIFY_LIBS)                       \
+       $(TPL_LIBS)                             \
+       $(ENCHANT_LIBS)                         \
+       $(LIBCHAMPLAIN_LIBS)                    \
+       $(GEOCLUE_LIBS)                         \
+       $(MEEGO_LIBS)                           \
+       $(WEBKIT_LIBS)                          \
+       $(top_builddir)/libempathy/libempathy.la
 
 check_c_sources = \
     $(libempathy_gtk_handwritten_source) \
@@ -123,11 +146,6 @@ check_c_sources = \
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
-libempathy_gtk_includedir = $(includedir)/libempathy-gtk/
-libempathy_gtk_include_HEADERS =               \
-       $(libempathy_gtk_headers)               \
-       empathy-gtk-enum-types.h
-
 uidir = $(datadir)/empathy
 ui_DATA =                                      \
        empathy-contact-widget.ui               \
@@ -136,7 +154,7 @@ ui_DATA =                                   \
        empathy-account-widget-jabber.ui        \
        empathy-account-widget-msn.ui           \
        empathy-account-widget-sip.ui           \
-       empathy-account-widget-salut.ui         \
+       empathy-account-widget-local-xmpp.ui    \
        empathy-account-widget-irc.ui           \
        empathy-account-widget-icq.ui           \
        empathy-account-widget-yahoo.ui         \
@@ -145,30 +163,31 @@ ui_DATA =                                         \
        empathy-status-preset-dialog.ui         \
        empathy-log-window.ui                   \
        empathy-chat.ui                         \
-       empathy-new-message-dialog.ui
+       empathy-contact-selector-dialog.ui      \
+       empathy-search-bar.ui
 
 empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
-       $(QUIET_GEN)( cd $(srcdir) && \
+       $(AM_V_GEN)( cd $(srcdir) && \
        sed -n -e 's/.*empathy_gtk_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
        $(libempathy_gtk_la_SOURCES) ) \
        | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       if cmp -s $@.tmp $@; then \
+       @if cmp -s $@.tmp $@; then \
                rm $@.tmp; \
        else \
                mv $@.tmp $@; \
        fi
 
 %-marshal.h: %-marshal.list Makefile
-       $(QUIET_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
 
 %-marshal.c: %-marshal.list Makefile
-       $(QUIET_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
+       $(AM_V_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
        $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
 
 empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
-       $(QUIET_GEN)true
+       $(AM_V_GEN)true
 stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
-       $(QUIET_GEN)(cd $(srcdir) \
+       $(AM_V_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#ifndef __LIBEMPATHY_GTK_ENUM_TYPES_H__\n" \
                        --fhead "#define __LIBEMPATHY_GTK_ENUM_TYPES_H__ 1\n\n" \
@@ -185,7 +204,7 @@ stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
        && echo timestamp > $(@F)
 
 empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
-       $(QUIET_GEN)(cd $(srcdir) \
+       $(AM_V_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#include <config.h>\n" \
                        --fhead "#include <glib-object.h>\n" \
@@ -203,12 +222,36 @@ empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
 
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libempathy-gtk.pc
-
 EXTRA_DIST =                   \
        $(ui_DATA)
 
+if HAVE_GEOCLUE
+libempathy_gtk_handwritten_source +=           \
+       empathy-location-manager.c
+
+libempathy_gtk_headers +=                      \
+       empathy-location-manager.h
+else
+EXTRA_DIST +=                                  \
+       empathy-location-manager.c              \
+       empathy-location-manager.h
+endif
+
+if HAVE_WEBKIT
+libempathy_gtk_handwritten_source +=           \
+       empathy-plist.c                         \
+       empathy-theme-adium.c
+libempathy_gtk_headers +=                      \
+       empathy-plist.h                         \
+       empathy-theme-adium.h
+else
+EXTRA_DIST +=                                  \
+       empathy-plist.c                         \
+       empathy-plist.h                         \
+       empathy-theme-adium.c                   \
+       empathy-theme-adium.h
+endif
+
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \
        stamp-empathy-gtk-enum-types.h