]> git.0d.be Git - empathy.git/blobdiff - extensions/Makefile.am
account-settings: allow to change the service
[empathy.git] / extensions / Makefile.am
index 843793a4c38bbffe9c1e492ae2e779f199be9821..1227b3f03b8c53c20abde30b72430069c722e0d6 100644 (file)
@@ -14,8 +14,11 @@ EXTRA_DIST = \
     misc.xml \
     Debug.xml \
     Logger.xml \
+    Connection_Interface_Renaming.xml \
     Authentication_TLS_Certificate.xml \
+    Channel_Interface_Credentials_Storage.xml \
     Channel_Type_Server_TLS_Connection.xml \
+    Chat_Manager.xml \
     $(NULL)
 
 noinst_LTLIBRARIES = libemp-extensions.la
@@ -54,14 +57,16 @@ BUILT_SOURCES = \
 
 CLEANFILES = $(BUILT_SOURCES)
 
+clean-local:
+       rm -rf _gen
+
 XSLTPROCFLAGS = --nonet --novalid
 
 # Generated files which can be generated for all categories simultaneously
 
-_gen/all.xml: all.xml $(wildcard *.xml)
+_gen/all.xml: all.xml $(wildcard *.xml) $(tools_dir)/xincludator.py
        @$(mkdir_p) _gen
-       $(AM_V_GEN)$(XSLTPROC) $(XSLTPROCFLAGS) --xinclude $(tools_dir)/identity.xsl \
-               $< > $@
+       $(AM_V_GEN)$(PYTHON) $(tools_dir)/xincludator.py $< > $@
 
 extensions.html: _gen/all.xml $(tools_dir)/doc-generator.xsl
        $(AM_V_GEN)$(XSLTPROC) $(XSLTPROCFLAGS) \
@@ -94,7 +99,7 @@ _gen/enums.h: _gen/all.xml \
        $(tools_dir)/c-constants-gen.py
        $(AM_V_GEN)$(PYTHON) $(tools_dir)/c-constants-gen.py \
                Emp \
-               $< > $@
+               $< _gen/enums
 
 _gen/interfaces-body.h _gen/interfaces.h: _gen/all.xml \
        $(tools_dir)/glib-interfaces-gen.py
@@ -105,10 +110,9 @@ _gen/interfaces-body.h _gen/interfaces.h: _gen/all.xml \
 # subclass you want to use with --subclass will need to have its own category,
 # although you can subdivide further if you want.
 
-_gen/misc.xml: misc.xml $(wildcard *.xml)
+_gen/misc.xml: misc.xml $(wildcard *.xml) $(tools_dir)/xincludator.py
        @$(mkdir_p) _gen
-       $(AM_V_GEN)$(XSLTPROC) $(XSLTPROCFLAGS) --xinclude $(tools_dir)/identity.xsl \
-               $< > $@
+       $(AM_V_GEN)$(PYTHON) $(tools_dir)/xincludator.py $< > $@
 
 _gen/cli-misc-body.h _gen/cli-misc.h: _gen/misc.xml \
        $(tools_dir)/glib-client-gen.py