Empathy should not require python-config. Fixes bug #525562 (Frederic Peters).
[empathy.git] / python / pyempathy / Makefile.am
1 PYDEFS=`pkg-config --variable=defsdir pygtk-2.0`
2
3 AM_CPPFLAGS =                                           \
4         -I.                                             \
5         -I$(top_srcdir)/libempathy                      \
6         -I$(top_srcdir)                                 \
7         -DDATADIR=\""$(datadir)"\"                      \
8         $(PYTHON_BINDING_CFLAGS)                        \
9         $(PYTHON_INCLUDES)                              \
10         $(WARN_CFLAGS)
11
12 BUILT_SOURCES =                                         \
13         pyempathy.c                                     
14
15 pyempathydir = $(pyexecdir)
16 pyempathy_LTLIBRARIES = empathy.la
17
18 empathy_la_SOURCES =                                    \
19         pyempathymodule.c                               \
20         pyempathy.c
21
22 empathy_la_LIBADD =                                     \
23         $(PYTHON_BINDING_LIBS)                          \
24         $(top_builddir)/libempathy/libempathy.la
25
26 empathy_la_LDFLAGS =                                    \
27         -module -avoid-version
28
29 pyempathy.c: pyempathy.override pyempathy.defs
30         pygtk-codegen-2.0                               \
31                 --prefix empathy                        \
32                 --register $(PYDEFS)/gdk-types.defs     \
33                 --register $(PYDEFS)/gtk-types.defs     \
34                 --override pyempathy.override           \
35                 pyempathy.defs > $@ 
36
37 EXTRA_DIST =                    \
38         pyempathy.override      \
39         pyempathy.defs
40
41 CLEANFILES = $(BUILT_SOURCES)
42