]> git.0d.be Git - empathy.git/blobdiff - tools/Makefile.am
Update tools from tp-glib 0.7.6
[empathy.git] / tools / Makefile.am
index 4bf514f163f7b3c8e84af69276f660e4e0f58a0e..bd1f4c00265566626d52d930e0350cfa06be440a 100644 (file)
@@ -1,3 +1,11 @@
+abs_top_builddir = @abs_top_builddir@
+
+noinst_SCRIPTS = telepathy-glib-env
+
+telepathy-glib-env: telepathy-glib-env.in Makefile
+       sed -e 's![@]abs_top_builddir[@]!$(abs_top_builddir)!' $< > $@
+       chmod +x $@
+
 EXTRA_DIST = \
     c-constants-generator.xsl \
     check-coding-style.mk \
@@ -15,8 +23,14 @@ EXTRA_DIST = \
     glib-ginterface-gen.py \
     glib-gtypes-generator.py \
     glib-signals-marshal-gen.py \
+    gobject-foo.py \
     identity.xsl \
-    libglibcodegen.py
+    libglibcodegen.py \
+    ls-interfaces.xsl \
+    make-all-async.xsl \
+    spec-to-introspect.xsl \
+    telepathy-glib-env.in \
+    with-session-bus.sh
 
 CLEANFILES = libglibcodegen.pyc libglibcodegen.pyo $(noinst_SCRIPTS)
 
@@ -31,11 +45,11 @@ glib-gtypes-generator.py: libglibcodegen.py
 glib-signals-marshal-gen.py: libglibcodegen.py
        touch $@
 
-TELEPATHY_GLIB_SRCDIR = $(top_srcdir)/../telepathy-glib
-maintainer-update-from-telepathy-glib:
+TELEPATHY_SPEC_SRCDIR = $(top_srcdir)/../telepathy-spec
+maintainer-update-from-telepathy-spec:
        set -e && cd $(srcdir) && \
        for x in $(EXTRA_DIST); do \
-               if test -f $(TELEPATHY_GLIB_SRCDIR)/tools/$$x; then \
-                       cp $(TELEPATHY_GLIB_SRCDIR)/tools/$$x $$x; \
+               if test -f $(TELEPATHY_SPEC_SRCDIR)/tools/$$x; then \
+                       cp $(TELEPATHY_SPEC_SRCDIR)/tools/$$x $$x; \
                fi; \
        done