]> git.0d.be Git - empathy.git/blobdiff - tools/Makefile.am
remove released flag
[empathy.git] / tools / Makefile.am
index bd1f4c00265566626d52d930e0350cfa06be440a..80f4ce346c63b1a13fed4c267fa0f5b6e2250dfa 100644 (file)
@@ -1,49 +1,67 @@
 abs_top_builddir = @abs_top_builddir@
 
-noinst_SCRIPTS = telepathy-glib-env
+noinst_SCRIPTS = telepathy-glib-env empathy-env
 
 telepathy-glib-env: telepathy-glib-env.in Makefile
        sed -e 's![@]abs_top_builddir[@]!$(abs_top_builddir)!' $< > $@
        chmod +x $@
 
+empathy-env: empathy-env.in Makefile
+       sed -e 's![@]abs_top_builddir[@]!$(abs_top_builddir)!' $< > $@
+       chmod +x $@
+
 EXTRA_DIST = \
-    c-constants-generator.xsl \
+    c-constants-gen.py \
     check-coding-style.mk \
     check-c-style.sh \
     check-misc.sh \
     check-whitespace.sh \
-    c-interfaces-generator.xsl \
     doc-generator.xsl \
+    flymake.mk \
+    git-which-branch.sh \
     glib-client-gen.py \
     glib-client-marshaller-gen.py \
-    glib-errors-enum-body.xsl \
-    glib-errors-enum-header.xsl \
-    glib-interfaces-generator.xsl \
-    glib-interfaces-body-generator.xsl \
+    glib-errors-check-gen.py \
+    glib-errors-str-gen.py \
     glib-ginterface-gen.py \
     glib-gtypes-generator.py \
-    glib-signals-marshal-gen.py \
+    glib-interfaces-gen.py \
     gobject-foo.py \
-    identity.xsl \
+    lcov.am \
+    libtpcodegen.py \
     libglibcodegen.py \
-    ls-interfaces.xsl \
-    make-all-async.xsl \
-    spec-to-introspect.xsl \
+    make-release-mail.py \
+    make-version-script.py \
+    manager-file.py \
+    shave.mk \
+    telepathy.am \
+    telepathy-glib.supp \
     telepathy-glib-env.in \
-    with-session-bus.sh
+    empathy-env.in \
+    test-wrapper.sh \
+    with-session-bus.sh \
+    xincludator.py
 
-CLEANFILES = libglibcodegen.pyc libglibcodegen.pyo $(noinst_SCRIPTS)
+CLEANFILES = libtpcodegen.pyc libtpcodegen.pyo libglibcodegen.pyc libglibcodegen.pyo $(noinst_SCRIPTS)
 
 all: $(EXTRA_DIST)
 
+libglibcodegen.py: libtpcodegen.py
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
+c-constants-gen.py: libglibcodegen.py
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
 glib-client-marshaller-gen.py: libglibcodegen.py
-       touch $@
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
+glib-errors-enum-body-gen.py: libglibcodegen.py
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
+glib-errors-enum-header-gen.py: libglibcodegen.py
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
 glib-ginterface-gen.py: libglibcodegen.py
-       touch $@
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
 glib-gtypes-generator.py: libglibcodegen.py
-       touch $@
-glib-signals-marshal-gen.py: libglibcodegen.py
-       touch $@
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
+glib-interfaces-gen.py: libglibcodegen.py
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
 
 TELEPATHY_SPEC_SRCDIR = $(top_srcdir)/../telepathy-spec
 maintainer-update-from-telepathy-spec: