]> git.0d.be Git - empathy.git/blobdiff - tools/Makefile.am
Updated Spanish Translation
[empathy.git] / tools / Makefile.am
index 4bf514f163f7b3c8e84af69276f660e4e0f58a0e..80f4ce346c63b1a13fed4c267fa0f5b6e2250dfa 100644 (file)
@@ -1,41 +1,73 @@
+abs_top_builddir = @abs_top_builddir@
+
+noinst_SCRIPTS = telepathy-glib-env empathy-env
+
+telepathy-glib-env: telepathy-glib-env.in Makefile
+       sed -e 's![@]abs_top_builddir[@]!$(abs_top_builddir)!' $< > $@
+       chmod +x $@
+
+empathy-env: empathy-env.in Makefile
+       sed -e 's![@]abs_top_builddir[@]!$(abs_top_builddir)!' $< > $@
+       chmod +x $@
+
 EXTRA_DIST = \
-    c-constants-generator.xsl \
+    c-constants-gen.py \
     check-coding-style.mk \
     check-c-style.sh \
     check-misc.sh \
     check-whitespace.sh \
-    c-interfaces-generator.xsl \
     doc-generator.xsl \
+    flymake.mk \
+    git-which-branch.sh \
     glib-client-gen.py \
     glib-client-marshaller-gen.py \
-    glib-errors-enum-body.xsl \
-    glib-errors-enum-header.xsl \
-    glib-interfaces-generator.xsl \
-    glib-interfaces-body-generator.xsl \
+    glib-errors-check-gen.py \
+    glib-errors-str-gen.py \
     glib-ginterface-gen.py \
     glib-gtypes-generator.py \
-    glib-signals-marshal-gen.py \
-    identity.xsl \
-    libglibcodegen.py
+    glib-interfaces-gen.py \
+    gobject-foo.py \
+    lcov.am \
+    libtpcodegen.py \
+    libglibcodegen.py \
+    make-release-mail.py \
+    make-version-script.py \
+    manager-file.py \
+    shave.mk \
+    telepathy.am \
+    telepathy-glib.supp \
+    telepathy-glib-env.in \
+    empathy-env.in \
+    test-wrapper.sh \
+    with-session-bus.sh \
+    xincludator.py
 
-CLEANFILES = libglibcodegen.pyc libglibcodegen.pyo $(noinst_SCRIPTS)
+CLEANFILES = libtpcodegen.pyc libtpcodegen.pyo libglibcodegen.pyc libglibcodegen.pyo $(noinst_SCRIPTS)
 
 all: $(EXTRA_DIST)
 
+libglibcodegen.py: libtpcodegen.py
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
+c-constants-gen.py: libglibcodegen.py
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
 glib-client-marshaller-gen.py: libglibcodegen.py
-       touch $@
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
+glib-errors-enum-body-gen.py: libglibcodegen.py
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
+glib-errors-enum-header-gen.py: libglibcodegen.py
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
 glib-ginterface-gen.py: libglibcodegen.py
-       touch $@
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
 glib-gtypes-generator.py: libglibcodegen.py
-       touch $@
-glib-signals-marshal-gen.py: libglibcodegen.py
-       touch $@
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
+glib-interfaces-gen.py: libglibcodegen.py
+       $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
 
-TELEPATHY_GLIB_SRCDIR = $(top_srcdir)/../telepathy-glib
-maintainer-update-from-telepathy-glib:
+TELEPATHY_SPEC_SRCDIR = $(top_srcdir)/../telepathy-spec
+maintainer-update-from-telepathy-spec:
        set -e && cd $(srcdir) && \
        for x in $(EXTRA_DIST); do \
-               if test -f $(TELEPATHY_GLIB_SRCDIR)/tools/$$x; then \
-                       cp $(TELEPATHY_GLIB_SRCDIR)/tools/$$x $$x; \
+               if test -f $(TELEPATHY_SPEC_SRCDIR)/tools/$$x; then \
+                       cp $(TELEPATHY_SPEC_SRCDIR)/tools/$$x $$x; \
                fi; \
        done