]> git.0d.be Git - empathy.git/blobdiff - tests/interactive/Makefile.am
Merge remote-tracking branch 'jonny/ft'
[empathy.git] / tests / interactive / Makefile.am
index 7770e768f0fac7febb80d43e3f5f529095eef2ff..e07ed65f7e4678292280295ea6af9044b8d37c35 100644 (file)
@@ -3,35 +3,38 @@ AM_CPPFLAGS =                                         \
        -I$(top_srcdir)                                 \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(EMPATHY_CFLAGS)                               \
+       $(EDS_CFLAGS)                                   \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy/libempathy.la                \
-       $(EMPATHY_LIBS)
+       $(EMPATHY_LIBS)                                         \
+       $(EDS_LIBS)
 
 noinst_PROGRAMS =                      \
-       contact-manager                 \
        empathy-logs                    \
-       empetit                         \
        test-empathy-account-assistant \
+       test-empathy-contact-blocking-dialog \
        test-empathy-presence-chooser   \
        test-empathy-status-preset-dialog \
-       test-empathy-protocol-chooser
+       test-empathy-protocol-chooser \
+       test-empathy-account-chooser
 
-contact_manager_SOURCES = contact-manager.c
 empathy_logs_SOURCES = empathy-logs.c
-empetit_SOURCES = empetit.c
+test_empathy_contact_blocking_dialog_SOURCES = test-empathy-contact-blocking-dialog.c
 test_empathy_presence_chooser_SOURCES = test-empathy-presence-chooser.c
 test_empathy_status_preset_dialog_SOURCES = test-empathy-status-preset-dialog.c
 test_empathy_protocol_chooser_SOURCES = test-empathy-protocol-chooser.c
 test_empathy_account_assistant_SOURCES = test-empathy-account-assistant.c
+test_empathy_account_chooser_SOURCES = test-empathy-account-chooser.c
 
 test_empathy_account_assistant_CFLAGS = -I$(top_srcdir)/src
 test_empathy_account_assistant_LDADD =                         \
-       $(top_builddir)/src/empathy-account-assistant.o \
-       $(top_builddir)/src/empathy-import-utils.o      \
-       $(top_builddir)/src/empathy-import-pidgin.o     \
-       $(top_builddir)/src/empathy-import-widget.o     \
+       $(top_builddir)/src/empathy-account-assistant.lo        \
+       $(top_builddir)/src/empathy-auto-salut-account-helper.lo        \
+       $(top_builddir)/src/empathy-import-pidgin.lo    \
+       $(top_builddir)/src/empathy-import-utils.lo     \
+       $(top_builddir)/src/empathy-import-widget.lo    \
        $(LDADD)