]> git.0d.be Git - empathy.git/blobdiff - tests/interactive/Makefile.am
Merge branch 'gnome-3-8'
[empathy.git] / tests / interactive / Makefile.am
index 24e674c6ad7d4cd2bca319fc8e20b0d82b698b8b..4ca1989eed213a08083264b1246160ad9834e02e 100644 (file)
@@ -1,42 +1,36 @@
 AM_CPPFLAGS =                                          \
        $(ERROR_CFLAGS)                                 \
-       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/libempathy                      \
+       -I$(top_srcdir)/libempathy-gtk                  \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(EMPATHY_CFLAGS)                               \
-       $(EDS_CFLAGS)                                   \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy/libempathy.la                \
-       $(EMPATHY_LIBS)                                         \
-       $(EDS_LIBS)
+       $(EMPATHY_LIBS)
 
 noinst_PROGRAMS =                      \
-       contact-manager                 \
        empathy-logs                    \
-       empetit                         \
-       test-empathy-account-assistant \
+       test-empathy-contact-blocking-dialog \
        test-empathy-presence-chooser   \
        test-empathy-status-preset-dialog \
        test-empathy-protocol-chooser \
-       test-empathy-account-chooser
+       test-empathy-account-chooser \
+       test-empathy-calendar-button \
+       test-empathy-roster-view \
+       test-empathy-dual-roster-view \
+       test-empathy-roster-model-aggregator
 
-contact_manager_SOURCES = contact-manager.c
 empathy_logs_SOURCES = empathy-logs.c
-empetit_SOURCES = empetit.c
+test_empathy_contact_blocking_dialog_SOURCES = test-empathy-contact-blocking-dialog.c
 test_empathy_presence_chooser_SOURCES = test-empathy-presence-chooser.c
 test_empathy_status_preset_dialog_SOURCES = test-empathy-status-preset-dialog.c
 test_empathy_protocol_chooser_SOURCES = test-empathy-protocol-chooser.c
-test_empathy_account_assistant_SOURCES = test-empathy-account-assistant.c
 test_empathy_account_chooser_SOURCES = test-empathy-account-chooser.c
-
-test_empathy_account_assistant_CFLAGS = -I$(top_srcdir)/src
-test_empathy_account_assistant_LDADD =                         \
-       $(top_builddir)/src/empathy-account-assistant.lo        \
-       $(top_builddir)/src/empathy-auto-salut-account-helper.lo        \
-       $(top_builddir)/src/empathy-import-pidgin.lo    \
-       $(top_builddir)/src/empathy-import-utils.lo     \
-       $(top_builddir)/src/empathy-import-widget.lo    \
-       $(LDADD)
+test_empathy_calendar_button_SOURCES = test-empathy-calendar-button.c
+test_empathy_roster_view_SOURCES = test-empathy-roster-view.c
+test_empathy_dual_roster_view_SOURCES = test-empathy-dual-roster-view.c
+test_empathy_roster_model_aggregator_SOURCES = test-empathy-roster-model-aggregator.c