]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
Updated Irish translation
[empathy.git] / tests / Makefile.am
index 6078e1a90e37c3d4df1859d7401a2c73356709e5..f96650e79094efe644f2aa3152c399c75fa17fa8 100644 (file)
@@ -14,7 +14,8 @@ AM_CPPFLAGS =                                         \
        -I$(top_srcdir)                                 \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(EMPATHY_CFLAGS)                               \
-       $(WARN_CFLAGS)
+       $(WARN_CFLAGS)                                  \
+       $(DISABLE_DEPRECATED)
 
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
@@ -23,16 +24,16 @@ LDADD =                                                             \
 
 noinst_PROGRAMS =                      \
        contact-manager                 \
-       contact-run-until-ready         \
-       contact-run-until-ready-2       \
        empetit                         \
-       test-empathy-presence-chooser
+       test-empathy-presence-chooser   \
+       test-empathy-status-preset-dialog \
+       test-empathy-profile-chooser
 
 contact_manager_SOURCES = contact-manager.c
-contact_run_until_ready_SOURCES = contact-run-until-ready.c
-contact_run_until_ready_2_SOURCES = contact-run-until-ready-2.c
 empetit_SOURCES = empetit.c
 test_empathy_presence_chooser_SOURCES = test-empathy-presence-chooser.c
+test_empathy_status_preset_dialog_SOURCES = test-empathy-status-preset-dialog.c
+test_empathy_profile_chooser_SOURCES = test-empathy-profile-chooser.c
 
 check_PROGRAMS = check-main
 TESTS = check-main
@@ -52,6 +53,11 @@ check_main_SOURCES =                             \
     check-empathy-chatroom.c                     \
     check-empathy-chatroom-manager.c
 
+check_c_sources = \
+    $(check_main_SOURCES)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
 check_main_LDADD = \
     @CHECK_LIBS@ \
     $(top_builddir)/libempathy-gtk/libempathy-gtk.la   \