]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
Remove obsolet test applications
[empathy.git] / tests / Makefile.am
index 5f8cbb6e4da5cf6f97c3d5aad3a4200c2be2ee00..cf9bc6a26825191b0bc2897a79939ccd44ef19a0 100644 (file)
@@ -6,10 +6,16 @@ include $(top_srcdir)/rules/check.mak
 
 SUPPRESSIONS=valgrind.supp dlopen.supp
 
+EXTRA_DIST =           \
+       test.manager    \
+       test.profile
+
 AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(EMPATHY_CFLAGS)                               \
-       $(WARN_CFLAGS)
+       $(WARN_CFLAGS)                                  \
+       $(DISABLE_DEPRECATED)
 
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
@@ -18,12 +24,12 @@ LDADD =                                                             \
 
 noinst_PROGRAMS =                      \
        contact-manager                 \
-       contact-run-until-ready         \
-       contact-run-until-ready-2
+       empetit                         \
+       test-empathy-presence-chooser
 
 contact_manager_SOURCES = contact-manager.c
-contact_run_until_ready_SOURCES = contact-run-until-ready.c
-contact_run_until_ready_2_SOURCES = contact-run-until-ready-2.c
+empetit_SOURCES = empetit.c
+test_empathy_presence_chooser_SOURCES = test-empathy-presence-chooser.c
 
 check_PROGRAMS = check-main
 TESTS = check-main
@@ -33,11 +39,20 @@ check_main_SOURCES =                             \
     check-helpers.h                              \
     check-libempathy.h                           \
     check-empathy-utils.c                        \
+    check-empathy-helpers.h                      \
+    check-empathy-helpers.c                      \
     check-irc-helper.h                           \
     check-irc-helper.c                           \
     check-empathy-irc-server.c                   \
     check-empathy-irc-network.c                  \
-    check-empathy-irc-network-manager.c
+    check-empathy-irc-network-manager.c          \
+    check-empathy-chatroom.c                     \
+    check-empathy-chatroom-manager.c
+
+check_c_sources = \
+    $(check_main_SOURCES)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
 
 check_main_LDADD = \
     @CHECK_LIBS@ \
@@ -49,4 +64,6 @@ check_main_CFLAGS = \
     @CHECK_CFLAGS@ \
     $(AM_CFLAGS)
 
-TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@
+TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
+                   MC_PROFILE_DIR=@abs_top_srcdir@/tests \
+                   MC_MANAGER_DIR=@abs_top_srcdir@/tests