]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
Updated Basque translation.
[empathy.git] / tests / Makefile.am
index 5f8cbb6e4da5cf6f97c3d5aad3a4200c2be2ee00..9a91e9d92cb7eeed777df2c55527dd44709612c1 100644 (file)
@@ -6,8 +6,13 @@ include $(top_srcdir)/rules/check.mak
 
 SUPPRESSIONS=valgrind.supp dlopen.supp
 
+EXTRA_DIST =           \
+       test.manager    \
+       test.profile
+
 AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)
 
@@ -19,11 +24,13 @@ LDADD =                                                             \
 noinst_PROGRAMS =                      \
        contact-manager                 \
        contact-run-until-ready         \
-       contact-run-until-ready-2
+       contact-run-until-ready-2       \
+       empetit
 
 contact_manager_SOURCES = contact-manager.c
 contact_run_until_ready_SOURCES = contact-run-until-ready.c
 contact_run_until_ready_2_SOURCES = contact-run-until-ready-2.c
+empetit_SOURCES = empetit.c
 
 check_PROGRAMS = check-main
 TESTS = check-main
@@ -33,11 +40,15 @@ check_main_SOURCES =                             \
     check-helpers.h                              \
     check-libempathy.h                           \
     check-empathy-utils.c                        \
+    check-empathy-helpers.h                      \
+    check-empathy-helpers.c                      \
     check-irc-helper.h                           \
     check-irc-helper.c                           \
     check-empathy-irc-server.c                   \
     check-empathy-irc-network.c                  \
-    check-empathy-irc-network-manager.c
+    check-empathy-irc-network-manager.c          \
+    check-empathy-chatroom.c                     \
+    check-empathy-chatroom-manager.c
 
 check_main_LDADD = \
     @CHECK_LIBS@ \
@@ -49,4 +60,6 @@ check_main_CFLAGS = \
     @CHECK_CFLAGS@ \
     $(AM_CFLAGS)
 
-TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@
+TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
+                   MC_PROFILE_DIR=@abs_top_srcdir@/tests \
+                   MC_MANAGER_DIR=@abs_top_srcdir@/tests