]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
Updated Oriya translation
[empathy.git] / tests / Makefile.am
index fdd67482a9cadcfa3eb11d8e5b7d572e2b67844c..863282627e8a514ed761775291db9cf77521e6f4 100644 (file)
@@ -4,16 +4,14 @@ CLEANFILES=
 
 SUPPRESSIONS=tp-glib.supp dlopen.supp
 
-EXTRA_DIST =           \
-       test.manager    \
-       test.profile
-
 AM_CPPFLAGS =                                          \
        $(ERROR_CFLAGS)                                 \
-       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/libempathy                      \
+       -I$(top_srcdir)/libempathy-gtk                  \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(TPAW_CFLAGS)                                  \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)                           \
        -DSRCDIR=\""$(abs_srcdir)"\"                    \
@@ -22,6 +20,7 @@ AM_CPPFLAGS =                                         \
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy/libempathy.la                \
+       $(TPAW_LIBS)                                            \
        $(EMPATHY_LIBS)                                         \
        $(NULL)
 
@@ -66,6 +65,18 @@ empathy_parser_test_SOURCES = empathy-parser-test.c \
 empathy_live_search_test_SOURCES = empathy-live-search-test.c \
      test-helper.c test-helper.h
 
+check_c_sources = \
+    $(empathy_tls_test_SOURCES) \
+    $(empathy_irc_server_test_SOURCES) \
+    $(empathy_irc_network_test_SOURCES) \
+    $(empathy_irc_network_manager_test_SOURCES) \
+    $(empathy_chatroom_test_SOURCES) \
+    $(empathy_chatroom_manager_test_SOURCES) \
+    $(empathy_parser_test_SOURCES) \
+    $(empathy_live_search_test_SOURCES)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
 TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
                    MC_PROFILE_DIR=@abs_top_srcdir@/tests \
                    MC_MANAGER_DIR=@abs_top_srcdir@/tests