]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
remove released flag
[empathy.git] / tests / Makefile.am
index eba5c022fad2fccb0884a2c566ee0d67bbc54b79..863282627e8a514ed761775291db9cf77521e6f4 100644 (file)
@@ -4,10 +4,6 @@ CLEANFILES=
 
 SUPPRESSIONS=tp-glib.supp dlopen.supp
 
-EXTRA_DIST =           \
-       test.manager    \
-       test.profile
-
 AM_CPPFLAGS =                                          \
        $(ERROR_CFLAGS)                                 \
        -I$(top_srcdir)/libempathy                      \
@@ -69,6 +65,18 @@ empathy_parser_test_SOURCES = empathy-parser-test.c \
 empathy_live_search_test_SOURCES = empathy-live-search-test.c \
      test-helper.c test-helper.h
 
+check_c_sources = \
+    $(empathy_tls_test_SOURCES) \
+    $(empathy_irc_server_test_SOURCES) \
+    $(empathy_irc_network_test_SOURCES) \
+    $(empathy_irc_network_manager_test_SOURCES) \
+    $(empathy_chatroom_test_SOURCES) \
+    $(empathy_chatroom_manager_test_SOURCES) \
+    $(empathy_parser_test_SOURCES) \
+    $(empathy_live_search_test_SOURCES)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
 TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
                    MC_PROFILE_DIR=@abs_top_srcdir@/tests \
                    MC_MANAGER_DIR=@abs_top_srcdir@/tests