]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
Updated Oriya translation
[empathy.git] / tests / Makefile.am
index 7821d8d2fdaf48abcecad419373cc7a2b57a5c7c..863282627e8a514ed761775291db9cf77521e6f4 100644 (file)
@@ -1,48 +1,57 @@
-SUBDIRS = interactive xml
+SUBDIRS = interactive xml certificates
 
 CLEANFILES=
 
-SUPPRESSIONS=valgrind.supp dlopen.supp
-
-EXTRA_DIST =           \
-       test.manager    \
-       test.profile
+SUPPRESSIONS=tp-glib.supp dlopen.supp
 
 AM_CPPFLAGS =                                          \
        $(ERROR_CFLAGS)                                 \
-       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/libempathy                      \
+       -I$(top_srcdir)/libempathy-gtk                  \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
+       -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(TPAW_CFLAGS)                                  \
        $(WARN_CFLAGS)                                  \
-       $(DISABLE_DEPRECATED)
+       $(DISABLE_DEPRECATED)                           \
+       -DSRCDIR=\""$(abs_srcdir)"\"                    \
+       $(NULL)
 
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy/libempathy.la                \
-       $(EMPATHY_LIBS)
+       $(TPAW_LIBS)                                            \
+       $(EMPATHY_LIBS)                                         \
+       $(NULL)
 
-TEST_PROGS =                                     \
-     empathy-utils-test                          \
+tests_list =  \
      empathy-irc-server-test                     \
      empathy-irc-network-test                    \
      empathy-irc-network-manager-test            \
      empathy-chatroom-test                       \
-     empathy-chatroom-manager-test
+     empathy-chatroom-manager-test               \
+     empathy-parser-test                         \
+     empathy-live-search-test                    \
+     empathy-tls-test
 
-empathy_utils_test_SOURCES = empathy-utils-test.c \
-     test-helper.c test-helper.h
+noinst_PROGRAMS = $(tests_list)
+TESTS = $(tests_list)
+
+empathy_tls_test_SOURCES = empathy-tls-test.c \
+     test-helper.c test-helper.h \
+     mock-pkcs11.c mock-pkcs11.h
 
 empathy_irc_server_test_SOURCES = empathy-irc-server-test.c \
      test-helper.c test-helper.h                       \
-     check-irc-helper.h check-irc-helper.c
+     test-irc-helper.h test-irc-helper.c
 
 empathy_irc_network_test_SOURCES = empathy-irc-network-test.c \
      test-helper.c test-helper.h                       \
-     check-irc-helper.h check-irc-helper.c
+     test-irc-helper.h test-irc-helper.c
 
 empathy_irc_network_manager_test_SOURCES = empathy-irc-network-manager-test.c \
      test-helper.c test-helper.h                       \
-     check-irc-helper.h check-irc-helper.c
+     test-irc-helper.h test-irc-helper.c
 
 empathy_chatroom_test_SOURCES = empathy-chatroom-test.c \
      test-helper.c test-helper.h
@@ -50,7 +59,23 @@ empathy_chatroom_test_SOURCES = empathy-chatroom-test.c \
 empathy_chatroom_manager_test_SOURCES = empathy-chatroom-manager-test.c \
      test-helper.c test-helper.h
 
-check_PROGRAMS = $(TEST_PROGS)
+empathy_parser_test_SOURCES = empathy-parser-test.c \
+     test-helper.c test-helper.h
+
+empathy_live_search_test_SOURCES = empathy-live-search-test.c \
+     test-helper.c test-helper.h
+
+check_c_sources = \
+    $(empathy_tls_test_SOURCES) \
+    $(empathy_irc_server_test_SOURCES) \
+    $(empathy_irc_network_test_SOURCES) \
+    $(empathy_irc_network_manager_test_SOURCES) \
+    $(empathy_chatroom_test_SOURCES) \
+    $(empathy_chatroom_manager_test_SOURCES) \
+    $(empathy_parser_test_SOURCES) \
+    $(empathy_live_search_test_SOURCES)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
 
 TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
                    MC_PROFILE_DIR=@abs_top_srcdir@/tests \
@@ -60,10 +85,10 @@ test-report: test-report.xml
        gtester-report $(top_builddir)/tests/$@.xml > \
          $(top_builddir)/tests/$@.html
 
-test-report.xml: ${TEST_PROGS} test
+test-report.xml: ${TESTS} test
 
-test: ${TEST_PROGS}
-       gtester -o test-report.xml -k --verbose ${TEST_PROGS}
+test: ${TESTS}
+       gtester -o test-report.xml -k --verbose ${TESTS}
 
 test-%: empathy-%-test
        gtester -o $@-report.xml -k --verbose $<