]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
Merge branch 'master' into tp-tube
[empathy.git] / tests / Makefile.am
index 9eb54132f72dd798fc49c31f1438c95ee4a86946..7740d1f8beeefd2b387e028f4464a980f9e44188 100644 (file)
@@ -1,13 +1,21 @@
+SUBDIRS = xml
+
 CLEANFILES=
 
 include $(top_srcdir)/rules/check.mak
 
 SUPPRESSIONS=valgrind.supp dlopen.supp
 
+EXTRA_DIST =           \
+       test.manager    \
+       test.profile
+
 AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(EMPATHY_CFLAGS)                               \
-       $(WARN_CFLAGS)
+       $(WARN_CFLAGS)                                  \
+       $(DISABLE_DEPRECATED)
 
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
@@ -15,9 +23,15 @@ LDADD =                                                              \
        $(EMPATHY_LIBS)
 
 noinst_PROGRAMS =                      \
-       contact-manager
+       contact-manager                 \
+       empetit                         \
+       test-empathy-presence-chooser   \
+       test-empathy-status-preset-dialog
 
 contact_manager_SOURCES = contact-manager.c
+empetit_SOURCES = empetit.c
+test_empathy_presence_chooser_SOURCES = test-empathy-presence-chooser.c
+test_empathy_status_preset_dialog_SOURCES = test-empathy-status-preset-dialog.c
 
 check_PROGRAMS = check-main
 TESTS = check-main
@@ -27,11 +41,20 @@ check_main_SOURCES =                             \
     check-helpers.h                              \
     check-libempathy.h                           \
     check-empathy-utils.c                        \
+    check-empathy-helpers.h                      \
+    check-empathy-helpers.c                      \
     check-irc-helper.h                           \
     check-irc-helper.c                           \
     check-empathy-irc-server.c                   \
     check-empathy-irc-network.c                  \
-    check-empathy-irc-network-manager.c
+    check-empathy-irc-network-manager.c          \
+    check-empathy-chatroom.c                     \
+    check-empathy-chatroom-manager.c
+
+check_c_sources = \
+    $(check_main_SOURCES)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
 
 check_main_LDADD = \
     @CHECK_LIBS@ \
@@ -43,3 +66,6 @@ check_main_CFLAGS = \
     @CHECK_CFLAGS@ \
     $(AM_CFLAGS)
 
+TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
+                   MC_PROFILE_DIR=@abs_top_srcdir@/tests \
+                   MC_MANAGER_DIR=@abs_top_srcdir@/tests