]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
Merge branch 'gnome-3-8'
[empathy.git] / tests / Makefile.am
index 40bd8933c5ec0010fb25349dd277a7b458e22584..67fe5d895d1706ededaacfec0f5c7f4c608b2343 100644 (file)
@@ -1,4 +1,4 @@
-SUBDIRS = interactive xml
+SUBDIRS = interactive xml certificates
 
 CLEANFILES=
 
@@ -10,12 +10,14 @@ EXTRA_DIST =                \
 
 AM_CPPFLAGS =                                          \
        $(ERROR_CFLAGS)                                 \
-       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/libempathy                      \
+       -I$(top_srcdir)/libempathy-gtk                  \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)                           \
+       -DSRCDIR=\""$(abs_srcdir)"\"                    \
        $(NULL)
 
 LDADD =                                                                \
@@ -24,7 +26,7 @@ LDADD =                                                               \
        $(EMPATHY_LIBS)                                         \
        $(NULL)
 
-TESTS =                                     \
+tests_list =  \
      empathy-irc-server-test                     \
      empathy-irc-network-test                    \
      empathy-irc-network-manager-test            \
@@ -34,8 +36,12 @@ TESTS =                                     \
      empathy-live-search-test                    \
      empathy-tls-test
 
+noinst_PROGRAMS = $(tests_list)
+TESTS = $(tests_list)
+
 empathy_tls_test_SOURCES = empathy-tls-test.c \
-     test-helper.c test-helper.h
+     test-helper.c test-helper.h \
+     mock-pkcs11.c mock-pkcs11.h
 
 empathy_irc_server_test_SOURCES = empathy-irc-server-test.c \
      test-helper.c test-helper.h                       \