]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
enable coding style checks in tests
[empathy.git] / tests / Makefile.am
index e7b162797e33744365c3a42c4d0b8a427393e591..42ebea555503b93846f3632f5c3158c68ac7df53 100644 (file)
@@ -6,8 +6,13 @@ include $(top_srcdir)/rules/check.mak
 
 SUPPRESSIONS=valgrind.supp dlopen.supp
 
+EXTRA_DIST =           \
+       test.manager    \
+       test.profile
+
 AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)
 
@@ -17,9 +22,17 @@ LDADD =                                                              \
        $(EMPATHY_LIBS)
 
 noinst_PROGRAMS =                      \
-       contact-manager
+       contact-manager                 \
+       contact-run-until-ready         \
+       contact-run-until-ready-2       \
+       empetit                         \
+       test-empathy-presence-chooser
 
 contact_manager_SOURCES = contact-manager.c
+contact_run_until_ready_SOURCES = contact-run-until-ready.c
+contact_run_until_ready_2_SOURCES = contact-run-until-ready-2.c
+empetit_SOURCES = empetit.c
+test_empathy_presence_chooser_SOURCES = test-empathy-presence-chooser.c
 
 check_PROGRAMS = check-main
 TESTS = check-main
@@ -29,11 +42,20 @@ check_main_SOURCES =                             \
     check-helpers.h                              \
     check-libempathy.h                           \
     check-empathy-utils.c                        \
+    check-empathy-helpers.h                      \
+    check-empathy-helpers.c                      \
     check-irc-helper.h                           \
     check-irc-helper.c                           \
     check-empathy-irc-server.c                   \
     check-empathy-irc-network.c                  \
-    check-empathy-irc-network-manager.c
+    check-empathy-irc-network-manager.c          \
+    check-empathy-chatroom.c                     \
+    check-empathy-chatroom-manager.c
+
+check_c_sources = \
+    $(check_main_SOURCES)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
 
 check_main_LDADD = \
     @CHECK_LIBS@ \
@@ -45,4 +67,6 @@ check_main_CFLAGS = \
     @CHECK_CFLAGS@ \
     $(AM_CFLAGS)
 
-TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@
+TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
+                   MC_PROFILE_DIR=@abs_top_srcdir@/tests \
+                   MC_MANAGER_DIR=@abs_top_srcdir@/tests