]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
enable coding style checks in tests
[empathy.git] / tests / Makefile.am
index 4e2654050500d37deece24c07d2a87268fd1973c..42ebea555503b93846f3632f5c3158c68ac7df53 100644 (file)
@@ -6,8 +6,13 @@ include $(top_srcdir)/rules/check.mak
 
 SUPPRESSIONS=valgrind.supp dlopen.supp
 
+EXTRA_DIST =           \
+       test.manager    \
+       test.profile
+
 AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)
 
@@ -19,11 +24,15 @@ LDADD =                                                             \
 noinst_PROGRAMS =                      \
        contact-manager                 \
        contact-run-until-ready         \
-       contact-run-until-ready-2
+       contact-run-until-ready-2       \
+       empetit                         \
+       test-empathy-presence-chooser
 
 contact_manager_SOURCES = contact-manager.c
 contact_run_until_ready_SOURCES = contact-run-until-ready.c
 contact_run_until_ready_2_SOURCES = contact-run-until-ready-2.c
+empetit_SOURCES = empetit.c
+test_empathy_presence_chooser_SOURCES = test-empathy-presence-chooser.c
 
 check_PROGRAMS = check-main
 TESTS = check-main
@@ -43,6 +52,11 @@ check_main_SOURCES =                             \
     check-empathy-chatroom.c                     \
     check-empathy-chatroom-manager.c
 
+check_c_sources = \
+    $(check_main_SOURCES)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
 check_main_LDADD = \
     @CHECK_LIBS@ \
     $(top_builddir)/libempathy-gtk/libempathy-gtk.la   \