]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
tls-test: Use a proper PKCS#11 mock module for testing
[empathy.git] / tests / Makefile.am
index b6c49509f4f8ab6378ccae7e8eb72e4431e75648..5b6d31f2819eba6806c9e3db2fcf60639e4807f1 100644 (file)
@@ -16,6 +16,7 @@ AM_CPPFLAGS =                                         \
        $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)                           \
+       -DSRCDIR=\""$(abs_srcdir)"\"                    \
        $(NULL)
 
 LDADD =                                                                \
@@ -38,7 +39,8 @@ noinst_PROGRAMS = $(tests_list)
 TESTS = $(tests_list)
 
 empathy_tls_test_SOURCES = empathy-tls-test.c \
-     test-helper.c test-helper.h
+     test-helper.c test-helper.h \
+     mock-pkcs11.c mock-pkcs11.h
 
 empathy_irc_server_test_SOURCES = empathy-irc-server-test.c \
      test-helper.c test-helper.h                       \