]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Merge remote-tracking branch 'origin/gnome-3-8'
[empathy.git] / src / Makefile.am
index 400b83b824a1be43d2aec645cb078fdf8efed1f1..db30af3f2cccf0b45e3bf11f5cc640ff923ae64f 100644 (file)
@@ -3,7 +3,11 @@ include $(top_srcdir)/tools/flymake.mk
 CPPFLAGS_COMMON =                                      \
        $(EMPATHY_CFLAGS)                               \
        $(ERROR_CFLAGS)                                 \
-       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/libempathy-gtk                  \
+       -I$(top_srcdir)/libempathy                      \
+       -I$(top_srcdir)/extensions                      \
+       -I$(top_builddir)/libempathy-gtk                \
+       -I$(top_builddir)/libempathy                    \
        -DG_LOG_DOMAIN=\"empathy\"                      \
        -DBIN_DIR=\"$(bindir)\"                         \
        $(DISABLE_DEPRECATED)                           \
@@ -14,6 +18,7 @@ AM_LDFLAGS = $(LIBM)
 AM_CPPFLAGS =                                          \
        $(CPPFLAGS_COMMON)                              \
        $(LIBCHAMPLAIN_CFLAGS)                          \
+       $(UOA_CFLAGS)                                   \
        $(NULL)
 
 LDADD =                                                                \
@@ -23,6 +28,7 @@ LDADD =                                                               \
        $(GCR_LIBS)                                             \
        $(EMPATHY_LIBS)                                         \
        $(LIBCHAMPLAIN_LIBS)                                    \
+       $(UOA_LIBS)                                             \
        $(NULL)
 
 noinst_LTLIBRARIES = libempathy-accounts-common.la
@@ -201,14 +207,10 @@ BUILT_SOURCES = \
 
 CLEANFILES = $(BUILT_SOURCES)
 
-empathy-chat-resources.c: empathy-chat.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies $(srcdir)/empathy-chat.gresource.xml)
-       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ \
-               --sourcedir=$(srcdir) \
-               --generate-source \
-               $<
-
-empathy-chat-resources.h: empathy-chat.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies $(srcdir)/empathy-chat.gresource.xml)
-       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ \
-               --sourcedir=$(srcdir) \
-               --generate-header \
-               $<
+chat_resource_files: $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir=$(srcdir) $(srcdir)/empathy-chat.gresource.xml)
+
+empathy-chat-resources.c: empathy-chat.gresource.xml $(chat_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
+
+empathy-chat-resources.h: empathy-chat.gresource.xml $(chat_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<