]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Merge remote-tracking branch 'origin/gnome-3-8'
[empathy.git] / src / Makefile.am
index 086d13be8c1330d4e8e7c1351a364443c24ded7b..db30af3f2cccf0b45e3bf11f5cc640ff923ae64f 100644 (file)
@@ -2,9 +2,12 @@ include $(top_srcdir)/tools/flymake.mk
 
 CPPFLAGS_COMMON =                                      \
        $(EMPATHY_CFLAGS)                               \
-       $(EDS_CFLAGS)                                   \
        $(ERROR_CFLAGS)                                 \
-       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/libempathy-gtk                  \
+       -I$(top_srcdir)/libempathy                      \
+       -I$(top_srcdir)/extensions                      \
+       -I$(top_builddir)/libempathy-gtk                \
+       -I$(top_builddir)/libempathy                    \
        -DG_LOG_DOMAIN=\"empathy\"                      \
        -DBIN_DIR=\"$(bindir)\"                         \
        $(DISABLE_DEPRECATED)                           \
@@ -15,6 +18,7 @@ AM_LDFLAGS = $(LIBM)
 AM_CPPFLAGS =                                          \
        $(CPPFLAGS_COMMON)                              \
        $(LIBCHAMPLAIN_CFLAGS)                          \
+       $(UOA_CFLAGS)                                   \
        $(NULL)
 
 LDADD =                                                                \
@@ -24,6 +28,7 @@ LDADD =                                                               \
        $(GCR_LIBS)                                             \
        $(EMPATHY_LIBS)                                         \
        $(LIBCHAMPLAIN_LIBS)                                    \
+       $(UOA_LIBS)                                             \
        $(NULL)
 
 noinst_LTLIBRARIES = libempathy-accounts-common.la
@@ -39,7 +44,6 @@ libempathy_accounts_common_la_SOURCES =                                       \
 
 libempathy_accounts_common_la_LIBADD =                                 \
         $(top_builddir)/libempathy-gtk/libempathy-gtk.la               \
-       $(EDS_LIBS)                                                     \
         $(EMPATHY_LIBS)                                                        \
         $(LIBCHAMPLAIN_LIBS)                                           \
        $(NULL)
@@ -87,6 +91,11 @@ empathy_chat_SOURCES =                                               \
        empathy-chat.c \
        $(NULL)
 
+nodist_empathy_chat_SOURCES = \
+       empathy-chat-resources.c \
+       empathy-chat-resources.h \
+       $(NULL)
+
 empathy_call_SOURCES = \
        empathy-call.c \
        empathy-call-factory.c \
@@ -103,6 +112,8 @@ empathy_call_SOURCES = \
        empathy-audio-sink.h \
        empathy-audio-src.c \
        empathy-audio-src.h \
+       empathy-audio-utils.c \
+       empathy-audio-utils.h \
        empathy-video-src.c \
        empathy-video-src.h \
        empathy-preferences.c \
@@ -120,7 +131,7 @@ empathy_call_SOURCES = \
        empathy-mic-monitor.c \
        empathy-mic-monitor.h
 
-empathy_call_CFLAGS = $(EMPATHY_CALL_CFLAGS)
+empathy_call_CFLAGS = $(EMPATHY_CALL_CFLAGS) -DGST_USE_UNSTABLE_API
 empathy_call_LDFLAGS = $(EMPATHY_CALL_LIBS)
 
 empathy_handwritten_source = \
@@ -182,9 +193,24 @@ ui_DATA =                                  \
 
 EXTRA_DIST =                   \
        $(autostart_DATA)       \
-       $(ui_DATA)
+       $(ui_DATA)              \
+       empathy-chat.js         \
+       empathy-chat.gresource.xml
 
 dist_man_MANS =                        \
        empathy.1 \
        empathy-accounts.1
 
+BUILT_SOURCES = \
+       $(nodist_empathy_chat_SOURCES) \
+       $(NULL)
+
+CLEANFILES = $(BUILT_SOURCES)
+
+chat_resource_files: $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir=$(srcdir) $(srcdir)/empathy-chat.gresource.xml)
+
+empathy-chat-resources.c: empathy-chat.gresource.xml $(chat_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
+
+empathy-chat-resources.h: empathy-chat.gresource.xml $(chat_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<