]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Fix a leaked ref.
[empathy.git] / src / Makefile.am
index 83b071790e6239702f3e44213ec2d6aed743c0e6..c7344c8c8ef55230f47c7fa4b7b6b27b874fe229 100644 (file)
@@ -1,29 +1,24 @@
-AM_CPPFLAGS =                                                  \
-       -I$(top_srcdir)                                         \
-       -DPREFIX="\"$(prefix)"\"                                \
-       -DSYSCONFDIR=\""$(sysconfdir)"\"                        \
-       -DDATADIR=\""$(datadir)"\"                              \
-       -DLIBDIR=\""$(libdir)"\"                                \
-       $(EMPATHY_CFLAGS)                                       \
+AM_CPPFLAGS =                                          \
+       -I$(top_srcdir)                                 \
+       -DPREFIX="\"$(prefix)"\"                        \
+       -DSYSCONFDIR=\""$(sysconfdir)"\"                \
+       -DDATADIR=\""$(datadir)"\"                      \
+       -DLIBDIR=\""$(libdir)"\"                        \
+       -DLOCALEDIR=\""$(datadir)/locale"\"             \
+       $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)
 
 LDADD =                                                                \
-       $(top_builddir)/libempathy/libempathy.la                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
+       $(top_builddir)/libempathy/libempathy.la                \
        $(EMPATHY_LIBS)
 
-bin_PROGRAMS = empathy empathy-accounts empathy-chat empathy-contact-list
-empathy_SOURCES =                                              \
-       empathy-main.c
-
-empathy_accounts_SOURCES =                                     \
-       empathy-accounts-main.c
+bin_PROGRAMS =                 \
+       empathy                 \
+       empathy-accounts
 
-empathy_chat_SOURCES =                                         \
-       empathy-chat-main.c
-
-empathy_contact_list_SOURCES =                                 \
-       empathy-contact-list-main.c
+empathy_SOURCES = empathy.c
+empathy_accounts_SOURCES = empathy-accounts.c
 
 # Dbus service file
 servicedir = $(datadir)/dbus-1/services
@@ -37,11 +32,6 @@ $(service_DATA): $(service_in_files) Makefile
 chandlerdir = $(datadir)/telepathy/managers
 chandler_DATA = empathy-chat.chandler
 
-autostartdir = $(datadir)/gnome/autostart
-autostart_in_files = empathy.desktop.in
-autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
-
 BUILT_SOURCES =                                                        \
        org.gnome.Empathy.Chat.service