]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Fix a leaked ref.
[empathy.git] / src / Makefile.am
index 4fe517debc024b40c3a8998aed6cef1418e7289a..c7344c8c8ef55230f47c7fa4b7b6b27b874fe229 100644 (file)
@@ -1,20 +1,44 @@
-AM_CPPFLAGS =                                          \
+AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
        -DPREFIX="\"$(prefix)"\"                        \
        -DSYSCONFDIR=\""$(sysconfdir)"\"                \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLIBDIR=\""$(libdir)"\"                        \
+       -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)
 
-bin_PROGRAMS = empathy
+LDADD =                                                                \
+       $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
+       $(top_builddir)/libempathy/libempathy.la                \
+       $(EMPATHY_LIBS)
 
-empathy_SOURCES =                                              \
-       empathy-main.c
+bin_PROGRAMS =                 \
+       empathy                 \
+       empathy-accounts
 
-empathy_LDADD = \
-       $(top_builddir)/libempathy/libempathy.la                                \
-       $(top_builddir)/libempathy-gtk/libempathy-gtk.la                        \
-       $(EMPATHY_LIBS)
+empathy_SOURCES = empathy.c
+empathy_accounts_SOURCES = empathy-accounts.c
+
+# Dbus service file
+servicedir = $(datadir)/dbus-1/services
+service_in_files = org.gnome.Empathy.Chat.service.in
+service_DATA = $(service_in_files:.service.in=.service)
+
+# Rule to make the service file with bindir expanded
+$(service_DATA): $(service_in_files) Makefile
+       @sed -e "s|\@bindir\@|$(bindir)|" $< > $@
+
+chandlerdir = $(datadir)/telepathy/managers
+chandler_DATA = empathy-chat.chandler
+
+BUILT_SOURCES =                                                        \
+       org.gnome.Empathy.Chat.service
+
+EXTRA_DIST =                                                   \
+       org.gnome.Empathy.Chat.service.in                       \
+       $(autostart_DATA)                                       \
+       $(chandler_DATA)
 
+CLEANFILES = $(BUILT_SOURCES)