]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Fix a leaked ref.
[empathy.git] / src / Makefile.am
index 2eb2d028666168b7f4ff4b9e8b3ea745f557ca1a..c7344c8c8ef55230f47c7fa4b7b6b27b874fe229 100644 (file)
@@ -1,28 +1,24 @@
-AM_CPPFLAGS =                                                  \
-       -I.                                                     \
-       -I$(top_srcdir)                                         \
-       $(EMPATHY_CFLAGS)                                       \
+AM_CPPFLAGS =                                          \
+       -I$(top_srcdir)                                 \
+       -DPREFIX="\"$(prefix)"\"                        \
+       -DSYSCONFDIR=\""$(sysconfdir)"\"                \
+       -DDATADIR=\""$(datadir)"\"                      \
+       -DLIBDIR=\""$(libdir)"\"                        \
+       -DLOCALEDIR=\""$(datadir)/locale"\"             \
+       $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)
 
-AM_LDFLAGS =                                                   \
-       $(top_builddir)/libempathy/libempathy.la                \
+LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
+       $(top_builddir)/libempathy/libempathy.la                \
        $(EMPATHY_LIBS)
 
-bin_PROGRAMS = empathy empathy-accounts empathy-chat empathy-contact-list
-
-empathy_SOURCES =                                              \
-       empathy-main.c                                          \
-       empathy-filter.c        empathy-filter.h
-empathy_accounts_SOURCES = empathy-accounts-main.c
-empathy_chat_SOURCES = empathy-chat-main.c
-empathy_contact_list_SOURCES = empathy-contact-list-main.c
+bin_PROGRAMS =                 \
+       empathy                 \
+       empathy-accounts
 
-# MC plugin
-#pluginlib_LTLIBRARIES = libempathy-filter-plugin.la
-#libempathy_filter_plugin_la_SOURCES = empathy-filter-plugin.c
-#libempathy_filter_plugin_la_CPPFLAGS = $(MISSION_CONTROL_PLUGINS_CFLAGS)
-#libempathy_filter_plugin_la_LDFLAGS = $(MISSION_CONTROL_PLUGINS_LIBS)
+empathy_SOURCES = empathy.c
+empathy_accounts_SOURCES = empathy-accounts.c
 
 # Dbus service file
 servicedir = $(datadir)/dbus-1/services
@@ -36,25 +32,11 @@ $(service_DATA): $(service_in_files) Makefile
 chandlerdir = $(datadir)/telepathy/managers
 chandler_DATA = empathy-chat.chandler
 
-autostartdir = $(datadir)/gnome/autostart
-autostart_in_files = empathy.desktop.in
-autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
-
-# Empathy filter DBus API
-empathy-filter-glue.h: empathy-filter.xml
-       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-server --output=$@ $<
-empathy-filter-gen.h: empathy-filter.xml
-       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-client --output=$@ $<
-
 BUILT_SOURCES =                                                        \
-       org.gnome.Empathy.Chat.service                          \
-       empathy-filter-glue.h                                   \
-       empathy-filter-gen.h
+       org.gnome.Empathy.Chat.service
 
 EXTRA_DIST =                                                   \
        org.gnome.Empathy.Chat.service.in                       \
-       empathy-filter.xml                                      \
        $(autostart_DATA)                                       \
        $(chandler_DATA)