]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Empathy is no more splitted into 2 processes. It makes debugging more
[empathy.git] / src / Makefile.am
index 0f0c2d0c081cefbdb32548e0e9ef504b2277eaf2..b89a4218de0b89227dd921b1b19a34853bf19a40 100644 (file)
@@ -1,4 +1,4 @@
-cppflags =                     \
+AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
        -DPREFIX="\"$(prefix)"\"                        \
        -DSYSCONFDIR=\""$(sysconfdir)"\"                \
        -I$(top_srcdir)                                 \
        -DPREFIX="\"$(prefix)"\"                        \
        -DSYSCONFDIR=\""$(sysconfdir)"\"                \
@@ -8,26 +8,16 @@ cppflags =                    \
        $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)
 
        $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)
 
-libs =                                                         \
+LDADD =                                                        \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(EMPATHY_LIBS)
 
 bin_PROGRAMS =                 \
        empathy                 \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(EMPATHY_LIBS)
 
 bin_PROGRAMS =                 \
        empathy                 \
-       empathy-chat            \
        empathy-accounts
 
        empathy-accounts
 
-empathy_SOURCES = empathy-main.c
-empathy_CPPFLAGS = $(cppflags)
-empathy_LDADD = $(libs)
-
-empathy_accounts_SOURCES = empathy-accounts-main.c
-empathy_accounts_CPPFLAGS = $(cppflags)
-empathy_accounts_LDADD = $(libs)
-
-empathy_chat_SOURCES = empathy-chat-main.c
-empathy_chat_CPPFLAGS = $(cppflags)
-empathy_chat_LDADD = $(libs)
+empathy_SOURCES = empathy.c
+empathy_accounts_SOURCES = empathy-accounts.c
 
 # Dbus service file
 servicedir = $(datadir)/dbus-1/services
 
 # Dbus service file
 servicedir = $(datadir)/dbus-1/services