]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Put in new VOIP UI
[empathy.git] / src / Makefile.am
index 8b9e63a193eace70f33f56415b28ba8c11217a2b..a49bfc5ad9b12a95462639555755201b6f2299c9 100644 (file)
@@ -1,71 +1,86 @@
-cppflags =                     \
-       -I.                     \
-       -I$(top_srcdir)         \
-       $(EMPATHY_CFLAGS)       \
+AM_CPPFLAGS =                                          \
+       -I$(top_srcdir)                                 \
+       $(EMPATHY_CFLAGS)                               \
+       $(LIBNOTIFY_CFLAGS)                             \
        $(WARN_CFLAGS)
 
-libs =                                                         \
+LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
+       $(top_builddir)/libempathy/libempathy.la                \
+       $(top_builddir)/extensions/libemp-extensions.la         \
+       $(LIBNOTIFY_LIBS)                                       \
        $(EMPATHY_LIBS)
 
 bin_PROGRAMS =                 \
        empathy                 \
-       empathy-chat            \
-       empathy-accounts        \
-       empathy-contact-list
+       empathy-logs
 
-empathy_SOURCES =                                              \
-       empathy-main.c                                          \
-       empathy-filter.c        empathy-filter.h
-empathy_CPPFLAGS = $(cppflags)
-empathy_LDADD = $(libs)
+BUILT_SOURCES= \
+       empathy-tube-dispatch-enumtypes.h \
+       empathy-tube-dispatch-enumtypes.c
 
-empathy_accounts_SOURCES = empathy-accounts-main.c
-empathy_accounts_CPPFLAGS = $(cppflags)
-empathy_accounts_LDADD = $(libs)
+empathy_SOURCES =                                                      \
+       bacon-message-connection.c bacon-message-connection.h           \
+       empathy.c                                                       \
+       empathy-about-dialog.c empathy-about-dialog.h                   \
+       empathy-accounts-dialog.c empathy-accounts-dialog.h             \
+       empathy-call-window.c empathy-call-window.h                     \
+       empathy-chatrooms-window.c empathy-chatrooms-window.h           \
+       empathy-chat-window.c empathy-chat-window.h                     \
+       empathy-event-manager.c empathy-event-manager.h                 \
+       empathy-ft-manager.c empathy-ft-manager.h                       \
+       empathy-import-dialog.c empathy-import-dialog.h                 \
+       empathy-import-pidgin.c empathy-import-pidgin.h                 \
+       empathy-main-window.c empathy-main-window.h                     \
+       empathy-misc.c empathy-misc.h                                   \
+       empathy-new-chatroom-dialog.c empathy-new-chatroom-dialog.h     \
+       empathy-preferences.c empathy-preferences.h                     \
+       empathy-sidebar.c empathy-sidebar.h                     \
+       empathy-status-icon.c empathy-status-icon.h                     \
+       empathy-tube-dispatch.c empathy-tube-dispatch.h                 \
+       ephy-spinner.c ephy-spinner.h
 
-empathy_chat_SOURCES = empathy-chat-main.c
-empathy_chat_CPPFLAGS = $(cppflags)
-empathy_chat_LDADD = $(libs)
+nodist_empathy_SOURCES = $(BUILT_SOURCES)
 
-empathy_contact_list_SOURCES = empathy-contact-list-main.c
-empathy_contact_list_CPPFLAGS = $(cppflags)
-empathy_contact_list_LDADD = $(libs)
+empathy_logs_SOURCES = empathy-logs.c
 
-# MC plugin
-#pluginlib_LTLIBRARIES = libempathy-filter-plugin.la
-#libempathy_filter_plugin_la_SOURCES = empathy-filter-plugin.c
-#libempathy_filter_plugin_la_CPPFLAGS = $(MISSION_CONTROL_PLUGINS_CFLAGS)
-#libempathy_filter_plugin_la_LIBADD = $(MISSION_CONTROL_PLUGINS_LIBS)
+gladedir = $(datadir)/empathy
+glade_DATA =                                   \
+       empathy-accounts-dialog.glade           \
+       empathy-call-window.glade               \
+       empathy-chatrooms-window.glade          \
+       empathy-chat-window.glade               \
+       empathy-ft-manager.glade                \
+       empathy-import-dialog.glade             \
+       empathy-main-window.glade               \
+       empathy-new-chatroom-dialog.glade       \
+       empathy-preferences.glade               \
+       empathy-status-icon.glade
 
-# Dbus service file
-servicedir = $(datadir)/dbus-1/services
-service_in_files = org.gnome.Empathy.Chat.service.in
-service_DATA = $(service_in_files:.service.in=.service)
+dist_man_MANS =                        \
+       empathy.1
 
-# Rule to make the service file with bindir expanded
-$(service_DATA): $(service_in_files) Makefile
-       @sed -e "s|\@bindir\@|$(bindir)|" $< > $@
+# rules for making the glib enum objects
+%-enumtypes.h: %.h Makefile.in
+       glib-mkenums \
+       --fhead "#ifndef __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n#define __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n\n#include <glib-object.h>\n\nG_BEGIN_DECLS\n" \
+       --fprod "/* enumerations from \"@filename@\" */\n" \
+       --vhead "GType @enum_name@_get_type (void);\n#define $(shell echo $* | tr [:lower:]- [:upper:]_ | sed 's/_.*//')_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n"         \
+       --ftail "G_END_DECLS\n\n#endif /* __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__ */" \
+       $< > $@
 
-chandlerdir = $(datadir)/telepathy/managers
-chandler_DATA = empathy-chat.chandler
+%-enumtypes.c: %.h Makefile.in
+       glib-mkenums \
+       --fhead "#include <$*.h>\n#include <$*-enumtypes.h>" \
+       --fprod "\n/* enumerations from \"@filename@\" */" \
+       --vhead "GType\n@enum_name@_get_type (void)\n{\n  static GType etype = 0;\n  if (etype == 0) {\n    static const G@Type@Value values[] = {"     \
+       --vprod "      { @VALUENAME@, \"@VALUENAME@\", \"@VALUENAME@\" }," \
+       --vtail "      { 0, NULL, NULL }\n    };\n    etype = g_@type@_register_static (\"@EnumName@\", values);\n  }\n  return etype;\n}\n" \
+       $< > $@
 
-# Empathy filter DBus API
-empathy-filter-glue.h: empathy-filter.xml
-       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-server --output=$@ $<
-empathy-filter-gen.h: empathy-filter.xml
-       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-client --output=$@ $<
-
-BUILT_SOURCES =                                                        \
-       org.gnome.Empathy.Chat.service                          \
-       empathy-filter-glue.h                                   \
-       empathy-filter-gen.h
-
-EXTRA_DIST =                                                   \
-       org.gnome.Empathy.Chat.service.in                       \
-       empathy-filter.xml                                      \
-       $(autostart_DATA)                                       \
-       $(chandler_DATA)
+EXTRA_DIST =                   \
+       $(autostart_DATA)       \
+       $(glade_DATA)
 
 CLEANFILES = $(BUILT_SOURCES)