]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Merge remote-tracking branch 'glassrose/debug-window-send-to-pastebin-button-658724'
[empathy.git] / src / Makefile.am
index cc4eebe30c86bbc51bce6ef16edab5e3efa97548..a2aa31d5b53db43d427e628b64f2169e4368234f 100644 (file)
@@ -1,7 +1,6 @@
 include $(top_srcdir)/tools/flymake.mk
 
 CPPFLAGS_COMMON =                                      \
-       $(YELL_CFLAGS)                                  \
        $(EMPATHY_CFLAGS)                               \
        $(EDS_CFLAGS)                                   \
        $(ERROR_CFLAGS)                                 \
@@ -24,7 +23,6 @@ LDADD =                                                               \
        $(top_builddir)/extensions/libemp-extensions.la         \
        $(GCR_LIBS)                                             \
        $(EMPATHY_LIBS)                                         \
-       $(YELL_LIBS)                                            \
        $(LIBCHAMPLAIN_LIBS)                                    \
        $(NULL)
 
@@ -32,9 +30,7 @@ noinst_LTLIBRARIES = libempathy-accounts-common.la
 
 libempathy_accounts_common_la_SOURCES =                                        \
        empathy-accounts-common.c empathy-accounts-common.h             \
-       empathy-account-assistant.c empathy-account-assistant.h         \
        empathy-accounts-dialog.c empathy-accounts-dialog.h             \
-       empathy-auto-salut-account-helper.c empathy-auto-salut-account-helper.h \
        empathy-import-dialog.c empathy-import-dialog.h                 \
        empathy-import-pidgin.c empathy-import-pidgin.h                 \
        empathy-import-widget.c empathy-import-widget.h                 \
@@ -48,31 +44,6 @@ libempathy_accounts_common_la_LIBADD =                                       \
         $(LIBCHAMPLAIN_LIBS)                                           \
        $(NULL)
 
-if HAVE_CONTROL_CENTER_EMBEDDING
-ccmodulesdir = $(CONTROL_CENTER_EXTENSIONDIR)
-ccmodules_LTLIBRARIES = libempathy-accounts-panel.la
-
-libempathy_accounts_panel_la_SOURCES =                         \
-       empathy-accounts-module.c                               \
-       cc-empathy-accounts-panel.c                             \
-       cc-empathy-accounts-panel.h                             \
-       $(NULL)
-
-libempathy_accounts_panel_la_CPPFLAGS =                                \
-       $(CPPFLAGS_COMMON)                                      \
-       $(CONTROL_CENTER_EMBEDDING_CFLAGS)                      \
-       -DLOCALEDIR=\""$(datadir)/locale"\"                     \
-       $(NULL)
-
-libempathy_accounts_panel_la_LDFLAGS = -export_dynamic -avoid-version -module -no-undefined -export-symbols-regex '^g_io_module_(load|unload)'
-
-libempathy_accounts_panel_la_LIBADD =                          \
-       $(EMPATHY_LIBS)                                         \
-       $(CONTROL_CENTER_EMBEDDING_LIBS)                        \
-       libempathy-accounts-common.la                           \
-       $(NULL)
-endif
-
 bin_PROGRAMS =                 \
        empathy                 \
        empathy-accounts        \
@@ -84,11 +55,6 @@ libexec_PROGRAMS = \
        empathy-av \
        empathy-chat
 
-BUILT_SOURCES = \
-       src-marshal.h \
-       src-marshal.c \
-       src-marshal.list
-
 empathy_accounts_SOURCES =                                             \
        empathy-accounts.c empathy-accounts.h                           \
        $(NULL)
@@ -127,8 +93,6 @@ empathy_av_SOURCES = \
        empathy-mic-monitor.h
        $(NULL)
 
-nodist_empathy_av_SOURCES = $(BUILT_SOURCES)
-
 empathy_av_CFLAGS = $(EMPATHY_AV_CFLAGS)
 empathy_av_LDFLAGS = $(EMPATHY_AV_LIBS) $(LIBM)
 
@@ -186,8 +150,6 @@ empathy_call_SOURCES = \
        empathy-mic-monitor.c \
        empathy-mic-monitor.h
 
-nodist_empathy_call_SOURCES = $(BUILT_SOURCES)
-
 empathy_call_CFLAGS = $(EMPATHY_CALL_CFLAGS)
 empathy_call_LDFLAGS = $(EMPATHY_CALL_LIBS)
 
@@ -200,8 +162,7 @@ empathy_handwritten_source = \
        empathy-event-manager.c empathy-event-manager.h                 \
        empathy-ft-manager.c empathy-ft-manager.h                       \
        empathy-invite-participant-dialog.c empathy-invite-participant-dialog.h \
-       empathy-main-window.c empathy-main-window.h                     \
-       empathy-migrate-butterfly-logs.c empathy-migrate-butterfly-logs.h \
+       empathy-roster-window.c empathy-roster-window.h                 \
        empathy-new-chatroom-dialog.c empathy-new-chatroom-dialog.h     \
        empathy-notifications-approver.c empathy-notifications-approver.h \
        empathy-call-observer.c empathy-call-observer.h                 \
@@ -224,8 +185,6 @@ empathy_LDADD =                                                             \
         $(LIBCHAMPLAIN_LIBS)                                           \
        $(NULL)
 
-nodist_empathy_SOURCES = $(BUILT_SOURCES)
-
 check_c_sources = \
     $(empathy_handwritten_source) \
     $(empathy_logs_SOURCES) \
@@ -244,8 +203,8 @@ ui_DATA =                                   \
        empathy-chatrooms-window.ui             \
        empathy-ft-manager.ui                   \
        empathy-import-dialog.ui                \
-       empathy-main-window.ui                  \
-       empathy-main-window-menubar.ui          \
+       empathy-roster-window.ui                        \
+       empathy-roster-window-menubar.ui                \
        empathy-new-chatroom-dialog.ui          \
        empathy-preferences.ui                  \
        empathy-status-icon.ui
@@ -268,33 +227,7 @@ EXTRA_DIST +=                                      \
        empathy-map-view.ui
 endif
 
-if !HAVE_CONTROL_CENTER_EMBEDDING
-EXTRA_DIST += $(libempathy_accounts_panel_la_SOURCES)
-else
-check_c_sources += $(libempathy_accounts_panel_la_SOURCES)
-endif
-
 dist_man_MANS =                        \
        empathy.1 \
        empathy-accounts.1
 
-src-marshal.list: $(empathy_SOURCES) $(empathy_call_SOURCES) Makefile.am
-       $(AM_V_GEN)( cd $(srcdir) && \
-       sed -n -e 's/.*src_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
-       $(empathy_SOURCES) $(empathy_av_SOURCES) $(empathy_call_SOURCES) ) \
-       | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       @if cmp -s $@.tmp $@; then \
-               rm $@.tmp; \
-       else \
-               mv $@.tmp $@; \
-       fi
-
-%-marshal.h: %-marshal.list Makefile
-       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
-
-%-marshal.c: %-marshal.list Makefile
-       $(AM_V_GEN)echo "#include \"src-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
-
-CLEANFILES = $(BUILT_SOURCES)
-