]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Merge remote-tracking branch 'glassrose/debug-window-send-to-pastebin-button-658724'
[empathy.git] / src / Makefile.am
index 380a1c46c628323415944a5855ad498c9cb709ea..a2aa31d5b53db43d427e628b64f2169e4368234f 100644 (file)
@@ -11,11 +11,10 @@ CPPFLAGS_COMMON =                                   \
        $(WARN_CFLAGS)                                  \
        $(NULL)
 
-AM_LDFLAGS = -lm
+AM_LDFLAGS = $(LIBM)
 AM_CPPFLAGS =                                          \
        $(CPPFLAGS_COMMON)                              \
        $(LIBCHAMPLAIN_CFLAGS)                          \
-       $(WEBKIT_CFLAGS)                                \
        $(NULL)
 
 LDADD =                                                                \
@@ -25,15 +24,13 @@ LDADD =                                                             \
        $(GCR_LIBS)                                             \
        $(EMPATHY_LIBS)                                         \
        $(LIBCHAMPLAIN_LIBS)                                    \
-       $(WEBKIT_LIBS)
+       $(NULL)
 
 noinst_LTLIBRARIES = libempathy-accounts-common.la
 
 libempathy_accounts_common_la_SOURCES =                                        \
        empathy-accounts-common.c empathy-accounts-common.h             \
-       empathy-account-assistant.c empathy-account-assistant.h         \
        empathy-accounts-dialog.c empathy-accounts-dialog.h             \
-       empathy-auto-salut-account-helper.c empathy-auto-salut-account-helper.h \
        empathy-import-dialog.c empathy-import-dialog.h                 \
        empathy-import-pidgin.c empathy-import-pidgin.h                 \
        empathy-import-widget.c empathy-import-widget.h                 \
@@ -45,34 +42,8 @@ libempathy_accounts_common_la_LIBADD =                                       \
        $(EDS_LIBS)                                                     \
         $(EMPATHY_LIBS)                                                        \
         $(LIBCHAMPLAIN_LIBS)                                           \
-        $(WEBKIT_LIBS)                                                 \
-       $(NULL)
-
-if HAVE_CONTROL_CENTER_EMBEDDING
-ccmodulesdir = $(CONTROL_CENTER_EXTENSIONDIR)
-ccmodules_LTLIBRARIES = libempathy-accounts-panel.la
-
-libempathy_accounts_panel_la_SOURCES =                         \
-       empathy-accounts-module.c                               \
-       cc-empathy-accounts-panel.c                             \
-       cc-empathy-accounts-panel.h                             \
        $(NULL)
 
-libempathy_accounts_panel_la_CPPFLAGS =                                \
-       $(CPPFLAGS_COMMON)                                      \
-       $(CONTROL_CENTER_EMBEDDING_CFLAGS)                      \
-       -DLOCALEDIR=\""$(datadir)/locale"\"                     \
-       $(NULL)
-
-libempathy_accounts_panel_la_LDFLAGS = -export_dynamic -avoid-version -module -no-undefined -export-symbols-regex '^g_io_module_(load|unload)'
-
-libempathy_accounts_panel_la_LIBADD =                          \
-       $(EMPATHY_LIBS)                                         \
-       $(CONTROL_CENTER_EMBEDDING_LIBS)                        \
-       libempathy-accounts-common.la                           \
-       $(NULL)
-endif
-
 bin_PROGRAMS =                 \
        empathy                 \
        empathy-accounts        \
@@ -84,11 +55,6 @@ libexec_PROGRAMS = \
        empathy-av \
        empathy-chat
 
-BUILT_SOURCES = \
-       src-marshal.h \
-       src-marshal.c \
-       src-marshal.list
-
 empathy_accounts_SOURCES =                                             \
        empathy-accounts.c empathy-accounts.h                           \
        $(NULL)
@@ -123,12 +89,12 @@ empathy_av_SOURCES = \
        empathy-video-widget.h \
        ev-sidebar.c \
        ev-sidebar.h \
+       empathy-mic-monitor.c \
+       empathy-mic-monitor.h
        $(NULL)
 
-nodist_empathy_av_SOURCES = $(BUILT_SOURCES)
-
 empathy_av_CFLAGS = $(EMPATHY_AV_CFLAGS)
-empathy_av_LDFLAGS = $(EMPATHY_AV_LIBS)
+empathy_av_LDFLAGS = $(EMPATHY_AV_LIBS) $(LIBM)
 
 empathy_auth_client_SOURCES =                                          \
        empathy-auth-client.c \
@@ -143,6 +109,52 @@ empathy_chat_SOURCES =                                             \
        gedit-close-button.c gedit-close-button.h \
        $(NULL)
 
+if HAVE_CALL
+
+libexec_PROGRAMS += empathy-call
+
+empathy_call_SOURCES = \
+       empathy-call.c \
+       empathy-call-factory.c \
+       empathy-call-factory.h \
+       empathy-call-handler.c \
+       empathy-call-handler.h \
+       empathy-call-window.c \
+       empathy-call-window.h \
+       empathy-call-window-fullscreen.c \
+       empathy-call-window-fullscreen.h \
+       empathy-about-dialog.c \
+       empathy-about-dialog.h \
+       empathy-audio-sink.c \
+       empathy-audio-sink.h \
+       empathy-audio-src.c \
+       empathy-audio-src.h \
+       empathy-video-src.c \
+       empathy-video-src.h \
+       empathy-video-widget.c \
+       empathy-video-widget.h \
+       empathy-preferences.c \
+       empathy-preferences.h \
+       ev-sidebar.c \
+       ev-sidebar.h \
+       empathy-camera-menu.c \
+       empathy-camera-menu.h \
+       empathy-mic-menu.c \
+       empathy-mic-menu.h \
+       empathy-rounded-actor.c \
+       empathy-rounded-actor.h \
+       empathy-rounded-rectangle.c \
+       empathy-rounded-rectangle.h \
+       empathy-rounded-texture.c \
+       empathy-rounded-texture.h \
+       empathy-mic-monitor.c \
+       empathy-mic-monitor.h
+
+empathy_call_CFLAGS = $(EMPATHY_CALL_CFLAGS)
+empathy_call_LDFLAGS = $(EMPATHY_CALL_LIBS)
+
+endif
+
 empathy_handwritten_source = \
        empathy-about-dialog.c empathy-about-dialog.h                   \
        empathy-chat-window.c empathy-chat-window.h                     \
@@ -150,10 +162,10 @@ empathy_handwritten_source = \
        empathy-event-manager.c empathy-event-manager.h                 \
        empathy-ft-manager.c empathy-ft-manager.h                       \
        empathy-invite-participant-dialog.c empathy-invite-participant-dialog.h \
-       empathy-main-window.c empathy-main-window.h                     \
-       empathy-migrate-butterfly-logs.c empathy-migrate-butterfly-logs.h \
+       empathy-roster-window.c empathy-roster-window.h                 \
        empathy-new-chatroom-dialog.c empathy-new-chatroom-dialog.h     \
        empathy-notifications-approver.c empathy-notifications-approver.h \
+       empathy-call-observer.c empathy-call-observer.h                 \
        empathy-preferences.c empathy-preferences.h                     \
        empathy-status-icon.c empathy-status-icon.h                     \
        empathy-chat-manager.c empathy-chat-manager.h                   \
@@ -171,11 +183,8 @@ empathy_LDADD =                                                            \
         $(top_builddir)/extensions/libemp-extensions.la                        \
         $(EMPATHY_LIBS)                                                        \
         $(LIBCHAMPLAIN_LIBS)                                           \
-        $(WEBKIT_LIBS)                                                 \
        $(NULL)
 
-nodist_empathy_SOURCES = $(BUILT_SOURCES)
-
 check_c_sources = \
     $(empathy_handwritten_source) \
     $(empathy_logs_SOURCES) \
@@ -189,11 +198,13 @@ ui_DATA =                                         \
        empathy-accounts-dialog.ui              \
        empathy-call-window-fullscreen.ui       \
        empathy-call-window.ui                  \
+       empathy-streamed-media-window.ui        \
        empathy-chat-window.ui                  \
        empathy-chatrooms-window.ui             \
        empathy-ft-manager.ui                   \
        empathy-import-dialog.ui                \
-       empathy-main-window.ui                  \
+       empathy-roster-window.ui                        \
+       empathy-roster-window-menubar.ui                \
        empathy-new-chatroom-dialog.ui          \
        empathy-preferences.ui                  \
        empathy-status-icon.ui
@@ -216,51 +227,7 @@ EXTRA_DIST +=                                      \
        empathy-map-view.ui
 endif
 
-if !HAVE_CONTROL_CENTER_EMBEDDING
-EXTRA_DIST += $(libempathy_accounts_panel_la_SOURCES)
-else
-check_c_sources += $(libempathy_accounts_panel_la_SOURCES)
-endif
-
 dist_man_MANS =                        \
        empathy.1 \
        empathy-accounts.1
 
-src-marshal.list: $(empathy_SOURCES) Makefile.am
-       $(AM_V_GEN)( cd $(srcdir) && \
-       sed -n -e 's/.*src_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
-       $(wildcard *.c) ) \
-       | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       @if cmp -s $@.tmp $@; then \
-               rm $@.tmp; \
-       else \
-               mv $@.tmp $@; \
-       fi
-
-%-marshal.h: %-marshal.list Makefile
-       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
-
-%-marshal.c: %-marshal.list Makefile
-       $(AM_V_GEN)echo "#include \"src-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
-
-# rules for making the glib enum objects
-%-enumtypes.h: %.h Makefile.in
-       $(AM_V_GEN)glib-mkenums \
-       --fhead "#ifndef __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n#define __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n\n#include <glib-object.h>\n\nG_BEGIN_DECLS\n" \
-       --fprod "/* enumerations from \"@filename@\" */\n" \
-       --vhead "GType @enum_name@_get_type (void);\n#define $(shell echo $* | tr [:lower:]- [:upper:]_ | sed 's/_.*//')_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n"         \
-       --ftail "G_END_DECLS\n\n#endif /* __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__ */" \
-       $< > $@
-
-%-enumtypes.c: %.h Makefile.in
-       $(AM_V_GEN)glib-mkenums \
-       --fhead "#include <$*.h>\n#include <$*-enumtypes.h>" \
-       --fprod "\n/* enumerations from \"@filename@\" */" \
-       --vhead "GType\n@enum_name@_get_type (void)\n{\n  static GType etype = 0;\n  if (etype == 0) {\n    static const G@Type@Value values[] = {"     \
-       --vprod "      { @VALUENAME@, \"@VALUENAME@\", \"@VALUENAME@\" }," \
-       --vtail "      { 0, NULL, NULL }\n    };\n    etype = g_@type@_register_static (\"@EnumName@\", values);\n  }\n  return etype;\n}\n" \
-       $< > $@
-
-CLEANFILES = $(BUILT_SOURCES)
-