]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Request presence again when an account is enabled
[empathy.git] / src / Makefile.am
index 8102666c68a60c4cb0d682aa8ba5ef9f555927ad..6896c03f3d5ac951defe7f91cf0316a1911fa0fc 100644 (file)
@@ -3,10 +3,12 @@ include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
+       -DG_LOG_DOMAIN=\"empathy\"                      \
        $(EMPATHY_CFLAGS)                               \
        $(LIBNOTIFY_CFLAGS)                             \
        $(LIBCHAMPLAIN_CFLAGS)                          \
-       $(DISABLE_DEPRECATED)
+       $(DISABLE_DEPRECATED)                           \
+       $(WEBKIT_CFLAGS)                                \
        $(WARN_CFLAGS)
 
 LDADD =                                                                \
@@ -15,7 +17,8 @@ LDADD =                                                               \
        $(top_builddir)/extensions/libemp-extensions.la         \
        $(LIBNOTIFY_LIBS)                                       \
        $(EMPATHY_LIBS)                                         \
-       $(LIBCHAMPLAIN_LIBS)
+       $(LIBCHAMPLAIN_LIBS)                                    \
+       $(WEBKIT_LIBS)
 
 bin_PROGRAMS =                 \
        empathy                 \
@@ -28,6 +31,7 @@ BUILT_SOURCES= \
 empathy_handwritten_source = \
        empathy.c                                                       \
        empathy-about-dialog.c empathy-about-dialog.h                   \
+       empathy-account-assistant.c empathy-account-assistant.h         \
        empathy-accounts-dialog.c empathy-accounts-dialog.h             \
        empathy-call-window.c empathy-call-window.h                     \
        empathy-call-window-fullscreen.c empathy-call-window-fullscreen.h                       \
@@ -35,9 +39,12 @@ empathy_handwritten_source = \
        empathy-debug-dialog.c empathy-debug-dialog.h                   \
        empathy-chat-window.c empathy-chat-window.h                     \
        empathy-event-manager.c empathy-event-manager.h                 \
+       empathy-import-mc4-accounts.c empathy-import-mc4-accounts.h     \
        empathy-ft-manager.c empathy-ft-manager.h                       \
        empathy-import-dialog.c empathy-import-dialog.h                 \
+       empathy-import-widget.c empathy-import-widget.h                 \
        empathy-import-pidgin.c empathy-import-pidgin.h                 \
+       empathy-import-utils.c empathy-import-utils.h                   \
        empathy-main-window.c empathy-main-window.h                     \
        empathy-misc.c empathy-misc.h                                   \
        empathy-new-chatroom-dialog.c empathy-new-chatroom-dialog.h     \
@@ -48,7 +55,6 @@ empathy_handwritten_source = \
 
 empathy_SOURCES =                                                      \
        $(empathy_handwritten_source)                                   \
-       bacon-message-connection.c bacon-message-connection.h           \
        ephy-spinner.c ephy-spinner.h
 
 nodist_empathy_SOURCES = $(BUILT_SOURCES)
@@ -80,7 +86,7 @@ EXTRA_DIST =                  \
        $(ui_DATA)
 
 if HAVE_LIBCHAMPLAIN
-empathy_SOURCES +=                             \
+empathy_handwritten_source +=                          \
        empathy-map-view.c                      \
        empathy-map-view.h