]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Fix typo in var name and don't link empathy-call-chandler on libemp-extensions.la...
[empathy.git] / src / Makefile.am
index 86ffade6b1dca987a788302713823552c47392da..59d6c5c1ffbeac7748e57ac79cf628de6fa31024 100644 (file)
@@ -1,58 +1,61 @@
-cflags = $(EMPATHY_CFLAGS)                                     \
-        $(WARN_CFLAGS)
-
-libs = $(top_builddir)/libempathy/libempathy.la                \
+AM_CPPFLAGS =                                          \
+       -I$(top_srcdir)                                 \
+       -DPREFIX="\"$(prefix)"\"                        \
+       -DSYSCONFDIR=\""$(sysconfdir)"\"                \
+       -DDATADIR=\""$(datadir)"\"                      \
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
+       -DLIBDIR=\""$(libdir)"\"                        \
+       -DLOCALEDIR=\""$(datadir)/locale"\"             \
+       $(EMPATHY_CFLAGS)                               \
+       $(WARN_CFLAGS)
+
+LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
+       $(top_builddir)/libempathy/libempathy.la                \
        $(EMPATHY_LIBS)
 
        $(EMPATHY_LIBS)
 
-bin_PROGRAMS = empathy empathy-accounts empathy-chat empathy-contact-list
-
-empathy_SOURCES = empathy-main.c
-empathy_CPPFLAGS = $(cflags)
-empathy_LDFLAGS = $(libs)
-
-empathy_accounts_SOURCES = empathy-accounts-main.c
-empathy_accounts_CPPFLAGS = $(cflags)
-empathy_accounts_LDFLAGS = $(libs)
-
-empathy_chat_SOURCES = empathy-chat-main.c
-empathy_chat_CPPFLAGS = $(cflags)
-empathy_chat_LDFLAGS = $(libs)
+bin_PROGRAMS =                 \
+       empathy                 \
+       empathy-accounts        \
+       empathy-logs
 
 
-empathy_contact_list_SOURCES = empathy-contact-list-main.c
-empathy_contact_list_CPPFLAGS = $(cflags)
-empathy_contact_list_LDFLAGS = $(libs)
+libexec_PROGRAMS =             \
+       empathy-chat-chandler
 
 
-# MC plugin
-pluginlib_LTLIBRARIES = libempathy-filter-plugin.la
-libempathy_filter_plugin_la_SOURCES = empathy-filter-plugin.c
-libempathy_filter_plugin_la_CPPFLAGS = $(MISSION_CONTROL_PLUGINS_CFLAGS)
-libempathy_filter_plugin_la_LDFLAGS = $(MISSION_CONTROL_PLUGINS_LIBS)
+empathy_SOURCES = empathy.c
+empathy_accounts_SOURCES = empathy-accounts.c
+empathy_logs_SOURCES = empathy-logs.c
+empathy_chat_chandler_SOURCES = empathy-chat-chandler.c
 
 
-# Dbus service file
+# Dbus service files
 servicedir = $(datadir)/dbus-1/services
 servicedir = $(datadir)/dbus-1/services
-service_in_files = org.gnome.Empathy.Chat.service.in
-service_DATA = $(service_in_files:.service.in=.service)
+service_DATA =                                                 \
+       org.gnome.Empathy.Chat.service
 
 
-# Rule to make the service file with bindir expanded
-$(service_DATA): $(service_in_files) Makefile
-       @sed -e "s|\@bindir\@|$(bindir)|" $< > $@
+%.service: %.service.in Makefile
+       @sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
 
 chandlerdir = $(datadir)/telepathy/managers
 
 chandlerdir = $(datadir)/telepathy/managers
-chandler_DATA = empathy-chat.chandler
-
-autostartdir = $(datadir)/gnome/autostart
-autostart_in_files = empathy.desktop.in
-autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
+chandler_DATA =                                                        \
+       empathy-chat.chandler
 
 BUILT_SOURCES =                                                        \
 
 BUILT_SOURCES =                                                        \
-       org.gnome.Empathy.Chat.service
+       $(service_DATA)
 
 EXTRA_DIST =                                                   \
        org.gnome.Empathy.Chat.service.in                       \
 
 EXTRA_DIST =                                                   \
        org.gnome.Empathy.Chat.service.in                       \
+       org.gnome.Empathy.Call.service.in                       \
        $(autostart_DATA)                                       \
        $(chandler_DATA)
 
 CLEANFILES = $(BUILT_SOURCES)
 
        $(autostart_DATA)                                       \
        $(chandler_DATA)
 
 CLEANFILES = $(BUILT_SOURCES)
 
+if HAVE_VOIP
+libexec_PROGRAMS += empathy-call-chandler
+empathy_call_chandler_SOURCES = empathy-call-chandler.c
+service_DATA +=        org.gnome.Empathy.Call.service
+chandler_DATA += empathy-call.chandler
+else
+EXTRA_DIST += empathy-call.chandler
+endif
+